The NEW Build Your Own Arcade Controls

Main => Main Forum => Topic started by: coldcoffeecup on April 14, 2016, 06:51:17 pm

Title: PACLED64 - Please help set multiple device IDs [x-post from software]
Post by: coldcoffeecup on April 14, 2016, 06:51:17 pm
I have 2 UltimateIO boards, and I'm trying to set the IDs for each of them, such that I can use them in the LEDBlinky program. I am using the RGB LED modules from paradise arcade found here. (http://www.paradisearcadeshop.com/button-leds/92-tropical-mood-light-rgb-5vdc-led.html)

2 assumptions I'm making:
1) PACLED64 is the correct software to configure the UltimateIO boards' IDs
2) I'm able to use 2 UltimateIO boards at the same time. I've had no problem with the controls themselves, but I can't for the life of me get the LEDs to work coherently.

Issues:
1) When I run the PACLED software, some variations of the brightness and random settings work, ONLY when 1 board or the other is connected.
2) I believe the process I need to go through is to plug in a single board, set the ID, disconnect, plug in the next board, set ID. Then I can have both connected uniquely. The problem I'm having is that within the PACLED64 software, the buttons to set the device IDs are always grayed out, such that I can't click on them. I have no clue how I'm supposed to change the device ID.
3) Although at one point a few weeks ago I was able to upgrade the firmware, now when I try and upgrade the firmware the tool reports there is no device connected, or upgrade is complete (before I select the firmware file).
4) Within the PACLED64 software, no matter which device ID I select (bottom left corner) it shows an UltimateIO connected, which seems to make no sense... even when I change to different device IDs, it still lets me clear flash, turn on LEDs, etc.

I'm getting increasingly frustrated by the minute. Any help to get me started, and move on to using the LEDBlinky program would be VERY much appreciated! Thanks in advance.
Title: Re: PACLED64 - Please help set multiple device IDs [x-post from software]
Post by: Scotty_C on April 14, 2016, 11:51:34 pm
hehe, I went down this frustration road as well ;)

I emailed Andy@ Ultimarc and got things squared away fairly easy. I flashed special  firmware (assigns a seperate ID) which I received from Andy on one of the UIO's and then needed to update the LEDBlinky PacDrive32.dll (added the PacDrive64.dll in there for good measure). After those 2 steps I can now say I have a 100% fully functional setup for 2 UIO's!! :)
Title: Re: PACLED64 - Please help set multiple device IDs [x-post from software]
Post by: wemr97dl on April 15, 2016, 01:54:49 am
I am going through the same thing right now, I can assign Id's 1,2,3 but anything else craps out the device and I have to reload the firmware. Andy is working on a solution for me right now
Title: Re: PACLED64 - Please help set multiple device IDs [x-post from software]
Post by: coldcoffeecup on April 15, 2016, 11:16:17 am
Man, FINALLY a response. I was getting worried :)

I emailed Andy@ Ultimarc and got things squared away fairly easy. I flashed special  firmware (assigns a seperate ID) which I received from Andy on one of the UIO's

So was this something he had to do for you, or did he send you the firmware and you updated it yourself?

Edit: I emailed Andy, and he provided an firmware similar to what you're describing. I'll try it out tonight and cross my fingers!
Title: Re: PACLED64 - Please help set multiple device IDs [x-post from software]
Post by: wemr97dl on April 15, 2016, 11:55:36 pm
He hasn't sent it yet I need to email him haven't had time to work on it
Title: Re: PACLED64 - Please help set multiple device IDs [x-post from software]
Post by: AndyWarne on April 19, 2016, 07:20:18 am
Note that the subject of this thread is misleading.

The board which needs the special firmware for ID #2 is the I-PAC Ultimate I/O board.

There is no need for any special firmware on the PacLED64 for other IDs.
Title: Re: PACLED64 - Please help set multiple device IDs [x-post from software]
Post by: GzStation on February 15, 2022, 04:51:23 am
Hi! I bought the iPac-Ultimate I/O. I try to configure my LED device with LEDBlinkyConfigWizard like the web site suggest me. The problem i have is seams to be similar…. that everytime i start LEDBlinky 8110 i have a message  :banghead: No LED Controllers Detected  :banghead: .   :dizzy: I've installed it on my laptop too to see if it was my main computer and have the same error... If i open the WinIPAC v2 App i can see that my board FW Vers. is 1.55 ( The last one ) ... So my computer can see it with the WinIPAC App. and i can play with it in games... So it is working...  :dunno It's like if the iPac Ultimate I/O don’t want to communicate with other apps like LEDBlinky… I’ll post when I’ll get a solution!