Main > Software Forum

CPWizard v2.63 Released

<< < (4/145) > >>

Lakersfan:
Here is an example of what it looks like on my screen before exporting...

headkaze:
No you're not having a brain fart ;) This is an understandable mistake.

It's your background image. It needs to be at a 4:3 ratio because it exports all images at a 4:3 ratio. So when your exporting the images are getting stretched.

So what you need to do is open your background image in Photoshop and change it's height.

An example of 4:3 ratio is 1024 x 768 (the default background size).

So the ratio is 1024 / 768 = 1.33~

Now if we take a look at your image it's 920 x 421. So we need to make it 4:3. That's 920 / 1.33~ = 690

So you need to change the height of your image to 690. In Photoshop you would select Image > Canvas Size... and type in 690 for the height.

The easier way would have been to make your background image 640 x 480, 800 x 600, 1024 x 768 or 1280 x 960 in the first place but it doesn't really matter as long as it's 4:3 ratio.

Hope that helps :)

EDIT: Oh I didn't read you were saying that none of your buttons were labelled. First thing you should do is exit CPWizard if it's running and delete the CPWizard.ini file. Then run CPWizard again and configure it including setting your Mame exe (no exporting will work without a Mame exe set) and going to Edit->Options->Mame and setting "Mame Layout" to your custom layout file. There were changes made through the new versions which broke backward compatibility so this is likely why it's not working. If that still doesn't work post your CPWizard.ini, CPWizard.log and layout xml file.

BTW I don't think CPWizard will work with really old versions of Mame  :dunno

Lakersfan:
Thanks for the tips. I was thinking it probably had something to do with my image size. I'll resize it in PS as suggested. As for the labels, I'll try that later this morning and post if I have any issues. BTW, I'm using Mame 1.21.

Great program, BTW.  :applaud:

Lakersfan:
I'm still having a problem when exporting. It reverts back to another control panel, as opposed to the one I created. This time, I deleted and uninstalled the entire program. I reinstalled 1.36 and loaded my xml file that I made back into the program. I went to export and the problem occurred.

Here are the files you needed as well as a screenshot of what everything looks like before I push the Go button:


--- Code: ---[General]
RunOnStartup=False
VolumeControlEnable=False
DynamicDataLoading=False
GhostScriptExe=C:\Program Files\gs\gs\bin\gswin32c.exe
[HideDesktop]
Enable=False
HideDesktopOnStartup=False
HideMouseCursor=False
HideDesktopUsingForms=False
SetWallpaperBlack=False
HideDesktopIcons=False
HideTaskbar=False
MoveMouseOffscreen=False
[Mame]
Layout=Mame
LayoutOverride=Mame
UseMameOutputSystem=True
Screenshot=True
DetectPause=True
SendPauseKey=False
SkipDisclaimer=False
UseOverlay=False
Version=0.121u1
Exe=I:\Emulators\Programs\mame\mamepm.exe
[Layout]
LayoutName=Arcade Reunion
[Display]
Rotate=0
Screen=\\.\DISPLAY1
ShowDelay=0
LabelLinkShow=True
LabelLinkSize=4
AllowOverlays=False
ForceColorKey=False
[Data]
ShowCPOnly=False
MameCP=True
GameInfo=True
GameHistory=True
MameInfo=True
ControlInfo=True
HighScore=True
MameArtwork=True
MameManual=True
MameIRC=True
EmulatorCP=True
EmulatorArtwork=True
EmulatorManual=True
OperationCard=True
NFO=True
EmulatorIRC=True
[Export]
ExportFolder=C:\Documents and Settings\Dad\Desktop\New Folder
[Input]
BackKeyExitMenu=False
ShowKey=KEYCODE_L
SelectKey=KEYCODE_LCONTROL
BackKey=KEYCODE_ESC
MenuUp=KEYCODE_UP
MenuDown=KEYCODE_DOWN
MenuLeft=KEYCODE_LEFT
MenuRight=KEYCODE_RIGHT
VolumeDown=KEYCODE_MINUS
VolumeUp=KEYCODE_EQUALS
ShowDesktop=KEYCODE_HOME
HideDesktop=KEYCODE_END
[IRC]
Server=irc.scifi-fans.net
Port=7000
Channel=#byoac
NickName=Dad
UserName=MAIN
RealName=CPWizard
IsInvisible=True
[LastWriteTime]
ControlsDat=12/11/2007 3:47:36 AM
ColorsIni=11/12/2007 6:14:26 AM
CatVer=12/13/2007 10:36:40 PM
NPlayers=12/19/2007 1:56:24 PM
HallOfFame=12/20/2007 12:15:10 PM
Mame=11/22/2007 8:35:45 PM
[DataFiles]
ControlsDat=C:\Program Files\CPWizard\Data\controls.xml
ColorsIni=C:\Program Files\CPWizard\Data\colors.ini
CatVer=C:\Program Files\CPWizard\Data\catver.ini
NPlayers=C:\Program Files\CPWizard\Data\nplayers.ini
ListInfo=C:\Program Files\CPWizard\Data\ListInfo.xml
MiniInfo=C:\Program Files\CPWizard\Data\MiniInfo.xml
CommandDat=C:\Program Files\CPWizard\Data\Command.dat
HistoryDat=C:\Program Files\CPWizard\Data\History.dat
MameInfoDat=C:\Program Files\CPWizard\Data\MameInfo.dat
HallOfFame=C:\Program Files\CPWizard\Data\HallOfFame.xml
StoryDat=C:\Program Files\CPWizard\Data\Story.dat
StdIni=C:\Program Files\CPWizard\Data\Std.ini
[MameFolders]
Cabinets=
Cfg=I:\Emulators\Programs\mame\cfg
CPanel=I:\Emulators\Programs\mame\cpanel
Ctrlr=
Flyers=
Icons=
Ini=
Manuals=
Marquees=I:\Emulators\Programs\mame\marquees
PCB=
Previews=
Select=
Snap=
Titles=

--- End code ---


--- Code: ---12/20/2007 10:46:29 AM: CPWizard v1.36
12/20/2007 10:46:29 AM: OS: Microsoft Windows XP Professional
12/20/2007 10:46:29 AM: Version: 5.1.2600
12/20/2007 10:46:29 AM: Build: 2600
12/20/2007 10:46:29 AM: RAM Total: 1023 MB
12/20/2007 10:46:29 AM: RAM Used: 394 MB
12/20/2007 10:46:30 AM: CPU: AMD Athlon(tm) 64 Processor 3500+
12/20/2007 10:46:30 AM: Video Card: NVIDIA GeForce FX 5500 (Microsoft Corporation)
12/20/2007 10:46:30 AM: Video Driver: 6.14.10.5673
12/20/2007 10:46:30 AM: Video RAM: 256 MB
12/20/2007 10:46:30 AM: Sound Card: Realtek AC'97 Audio for VIA (R) Audio Controller
12/20/2007 10:46:30 AM: .NET: .NET Framework 2.0 Installed
12/20/2007 10:46:30 AM: Initializing InterComm Manager
12/20/2007 10:46:30 AM: Initializing Cmd Line Watcher
12/20/2007 10:46:30 AM: Starting InterComm Manager
12/20/2007 10:46:30 AM: Initializing Display Manager
12/20/2007 10:46:30 AM: Initializing Program Manager
12/20/2007 10:46:30 AM: Reading Config
12/20/2007 10:46:30 AM: Initializing Main Menu
12/20/2007 10:46:30 AM: Initializing Layout Manager
12/20/2007 10:46:30 AM: Initializing Game Info
12/20/2007 10:46:30 AM: Initializing History Dat
12/20/2007 10:46:30 AM: Initializing MameInfo Dat
12/20/2007 10:46:30 AM: Initializing Command Dat
12/20/2007 10:46:30 AM: Initializing Story Dat
12/20/2007 10:46:30 AM: Initializing Artwork Manager
12/20/2007 10:46:30 AM: Initializing Mame Manuals
12/20/2007 10:46:30 AM: Initializing Emulator Manuals
12/20/2007 10:46:30 AM: Initializing Emulator OpCard
12/20/2007 10:46:30 AM: Initializing NFO Viewer
12/20/2007 10:46:31 AM: Initializing IRC
12/20/2007 10:46:31 AM: Initializing SendKeys
12/20/2007 10:46:31 AM: Initializing Mame Interop
12/20/2007 10:46:31 AM: Initializing Mame Manager
12/20/2007 10:46:31 AM: Initializing Emulator Manager
12/20/2007 10:46:31 AM: Initializing Keyboard Hook
12/20/2007 10:46:31 AM: Initializing Direct Input
12/20/2007 10:46:31 AM: Initializing MCE Remote
12/20/2007 10:46:31 AM: Initializing Input Manager
12/20/2007 10:46:31 AM: Initializing Profiles
12/20/2007 10:46:31 AM: Initializing Bezel
12/20/2007 10:46:31 AM: Reading Mame Data
12/20/2007 10:46:31 AM: Creating MainBitmap
12/20/2007 10:46:31 AM: Starting Mame Interop
12/20/2007 10:46:57 AM: Reading Mame Data
12/20/2007 10:46:57 AM: Setting Options For Mame Version 0.121u1
12/20/2007 10:46:57 AM: Reading Controls Xml
12/20/2007 10:46:57 AM: Reading Colors Ini
12/20/2007 10:46:57 AM: Reading CatVer Ini
12/20/2007 10:46:57 AM: Reading NPlayers Ini
12/20/2007 10:46:58 AM: Reading Hall Of Fame Xml
12/20/2007 10:46:58 AM: Reading ListInfo Xml
12/20/2007 10:47:06 AM: Writing MiniInfo Xml
12/20/2007 10:47:06 AM: Mame Version 0.121u1
12/20/2007 10:47:06 AM: Initializing Mini Info Xml
12/20/2007 10:47:06 AM: Initializing Mame Ini
12/20/2007 10:47:06 AM: Reading Mame Ini
12/20/2007 10:47:06 AM: Initializing Mame Cfg
12/20/2007 10:47:06 AM: Initializing Mame Command Line
12/20/2007 10:47:06 AM: Reading History Dat
12/20/2007 10:47:07 AM: Reading MameInfo Dat
12/20/2007 10:47:07 AM: Reading Command Dat
12/20/2007 10:47:08 AM: Reading Story Dat
12/20/2007 10:47:08 AM: Reading Mini Info Xml
12/20/2007 10:47:09 AM: Reading All Mame Cfg's
12/20/2007 10:48:14 AM: Shutting Down Program Manager
12/20/2007 10:48:14 AM: Writing Config
12/20/2007 10:48:14 AM: Exiting

--- End code ---

headkaze:

--- Quote ---and going to Edit->Options->Mame and setting "Mame Layout" to your custom layout file
--- End quote ---

You still have to set your layout for Mame. It does not use the layout you have loaded, it uses the layout in the above option. Let me know how you go :)

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version