Arcade Collecting > Merit/JVL Touchscreen

2009 Megatouch Ion. Was working, changed battery, now totally dead. Please help.

I have a 2008 Ion that I just swapped out the hard drive & key to upgrade to a 2009. No problem, worked perfect . Ran for a day on the bench, powered up & down several times no problem. I thought I'd change the battery since it hasn't been changed in forever and i had some new ones, so I did. Go to power on and it's deader than dead??? Nothing, no led lights on motherboard, no fans, certainly no monitor, nothing, just dead. Put the old battery back in, checked all connections, checked power supply. Still dead. I'm at a loss. Wish I never touched it.
My tech skills are limited.
 Any help would be appreciated.
Found the answer to my own problem and thought I'd share. Actually found it on an old post in a forum right here on Forum controls.
There was a similar problem and A poster suggested jumpstarting the motherboard by taking a paper clip or piece of wire. On the 20 pin connector on the motherboard, find the green wire (14th pin and the black one next to it(15th), shove one end in each hole alongside the wires thus shorting them, then power on. I almost fell off my f-ing chair when it worked. I did also have to hook up a keyboard, F1 to cmos and save settings. But it worked. Hope this helps someone. Geoff

lol, i just replied to your PM with basicly the same directions.


[0] Message Index

Go to full version