Main > Lightguns

Gun4ir Default Feedback Not Working after Adding Mamehooker

<< < (2/2)

JayBee:

--- Quote from: vd2021 on February 10, 2024, 05:22:21 pm ---Can you tell me where I can find the code data/info used in the "MameStop=" line? I believe this is where the issue is.

--- End quote ---
That's the thing, your mamestop command is fine, you could even reduce it to just E as it reinitialize the whole gun settings.
Like this:
cmw 4 E
And it should work (it does work perfectly for me and other users), but only if mamehooker does receive and send the command before mame gets shut down.
Are you using anything that force shut down mamehooker?

vd2021:

--- Quote from: JayBee on February 12, 2024, 12:36:39 am ---
--- Quote from: vd2021 on February 10, 2024, 05:22:21 pm ---Can you tell me where I can find the code data/info used in the "MameStop=" line? I believe this is where the issue is.

--- End quote ---
That's the thing, your mamestop command is fine, you could even reduce it to just E as it reinitialize the whole gun settings.
Like this:
cmw 4 E
And it should work (it does work perfectly for me and other users), but only if mamehooker does receive and send the command before mame gets shut down.
Are you using anything that force shut down mamehooker?

--- End quote ---

JB,
Thanks, I'll try shortening the lines to match your suggestion and check my scripts to see if I set a line to close mamehooker in any of them.

vd2021:

--- Quote from: JayBee on February 12, 2024, 12:36:39 am ---
--- Quote from: vd2021 on February 10, 2024, 05:22:21 pm ---Can you tell me where I can find the code data/info used in the "MameStop=" line? I believe this is where the issue is.

--- End quote ---
That's the thing, your mamestop command is fine, you could even reduce it to just E as it reinitialize the whole gun settings.
Like this:
cmw 4 E
And it should work (it does work perfectly for me and other users), but only if mamehooker does receive and send the command before mame gets shut down.
Are you using anything that force shut down mamehooker?

--- End quote ---

Progress and some discoveries.

*Running mamehooker in Win7 Compatible mode.
*Only ran mamehooker as "admin" on initial opening.
*I set my Gun4ir light guns to cports 1, 2, 3 and 4, relatively, and changed the "MameStart=" line cport numbers accordingly.
*Changed ini "MameStop=" to "cmw 1 E, cmw 2 E, cmw 3 E, cmw 4 E"
*I set mamehooker to launch at startup
*****Currenty Functionality******
*If I launch a game, where the ini is set, I get a solenoid trigger when the game hooks and the feedback works as expected with the game.
*If I launch a game, that hooks and there is not an ini (1st run), or the ini has not been populated with the code/commands, the light guns go into a state of being hooked and there is no feedback during game play.
*Senarion-1 Following either of these two situations*.....The light guns stay in a state of being hooked. If a setup game (ini populated) is launched I get the solenoid trigger when that game hooks and the feedback works as expected.
*Senarion-2 Following either of these two situations*.....The light guns stay in a state of being hooked. If a game is launched for the 1st time, or does not have the ini populated, the light guns stay in a hooked state and ther is no feedback during game play.
*Senarion-3 Following either of these two situations*.....If I close MameHooker, using the taskbar dropdown, I get a solenoid trigger and the lightguns go back to default functionality.
*Senarion-4 Following either of these two situations*.....This is the most unique of my discoveries. RPCS3 and System 357 games. Launching and closing either of these (DeadStorm Pirates, Dark Escape and Sailor Zombies) ALWAYS hook and give a solenoid trigger. At closing, either of these games, I get a solenoid trigger and the light guns go back to a default state. Regardless of which state the light gun is in it's default or a mamehooked state, at game launch. [I've been using one of these games to "reset" the light guns so I don't have to use a keyboard to taskbar exit and restart mamehooker].

I'm hoping this info can help someone find my issue/s.

Navigation

[0] Message Index

[*] Previous page

Go to full version