Main > Monitor/Video Forum

Odd D9200 behavior

(1/4) > >>

got a WG D9200 in. it's had blanked out clicking with the SMPS in overload, so brought it in to be worked on.

replaced some power supply caps and got it back up and displaying again.

except after it stays on for about 2 minutes and starts warming up, the bottom half of the screen starts getting tiny little horizontal scanline jitters that get worse and worse...  also oddly, a slightly darker horizontal line about the height of a single scanline forms across the width of the screen exactly in the middle just as these jitters start getting to their worst... before long the entire screen is randomly jittering.

i replaced all the capacitors around the IC403 deflection processor IC, but it didn't seem to help any.  Adjusting the monitor brightness down seems to alleviate the jitters somewhat, they are still present, but much less so....and turning it way up makes it much worse. another odd behavior is that the jitters will get REALLY bad then all of a sudden it almost stops before it starts getting worse again, as if whatever is causing it has suddenly drifted back into specification again, before drifting back out again.

seems the Wells Gardner approach to generally anything image distortion wise in their troubleshooting guide is to replace IC403. i don't want to just shotgun order a new KA2147 processor without exhausting other options first. anybody else encounter this know what it is? seems like something is causing the horizontal scanline sync timing to be randomly early/late started instead of the timing being even.

link to a short snap of what it looks like:

and a youtube of the progression of the video image degradation

Your video is set to private. Not that it's likely i'll be able to help, but even so :)

my bad. i thought i set it to unlisted. i fixed it.

the video kinda makes it look like the set is starting to love sync, at least at the timestamp where the distortion begins it does. Could it be a low supply voltage on the IC you mention, or components around it?

looks like main VCC U403 (S1D2147A01) is expecting 10.8 to 13.2 spec'd and it is at 11.62 at startup, voltage does not change a single bit when it starts the jitters.

looks like i'm going to have to bust out the oscilloscope.  hopefully it still works.


[0] Message Index

[#] Next page

Go to full version