Arcade Collecting > Merit/JVL Touchscreen

Maxx Sapphire boot issue / rescue disks

(1/3) > >>

Hey everyone... been a while, glad to see some familiar faces :)

I have come across a nice looking maxx sapphire machine that I wanted to help restore for a friends 92 y/o father, to play with. Unfortunately, I have come to a dead-end with it.

I started out by booting it up to a "crc error --system halted" message... so i replaced the bios battery, reset bios to defaults and set the date... Same crc error persists.

Then went online and found ISO of the sapphire / force 2004 rescue disks, which I burned and tried to boot off of... result, system times out on the "Loading..." message. I tried multiple times and received strange inconsistencies when they kernel was trying to load... So I reseated the processor and replaced the ram... seemed to clear that up and allow me into the rescue / refresh program.

Now, I am getting CDROM errors... so I played with the IDE channel configuration (slave/master) and replaced the ribbon cables. Tried multiple combinations and came up with the following...

The primary IDE channel on the motherboard seems to be toast. Whichever device i have hooked up to it... comes up with errors on boot the process. I have also tried using a dual terminal ribbon cable, with both devices hooked on to the secondary IDE mobo channel. This comes up with a kernel panic termination.

I am left with ether buying a new mobo or hd / flash kit... I really just wanted to get this thing up and running asap, as it is a favor for a friend.

Is there anyone that would be willing to do a solid and provide sapphire hd image ?..



The crc error is bad motherboard 99% of the time in my experience. Curiously enough, the machine should still run dos based versions like emerald and diamond.

I can send you a sapphire image if you still want to try.

Hey there Mike, thanks for the reply good sir!

Yup, for sure one of the IDE channels are toast... However, I was able to dig through my old hard drives from 2013, when I used to do this sort of thing more often. Found a CHD backup of a sapphire and couple others... Good thing I never trash things  :P

Cloned a drive and hooked up... works !  8)

Thanks again Mike

That's great to know. I've never tried the other ide channel before. So did you get it running by hooking up the drive to secondary channel?

Dang, I spoke too soon... I took a second look and saw that it was indeed the primary channel, I had the sapphire HD I cloned, was hooked up to.

Randomly, the primary channel seemed to work for a few boots and I played for a while. However, messing around with the system and changing the channel to secondary (which i can confirm now... does not work / boot... just hangs when loading boot loader) The primary channel started giving me boot errors again.  :angry:

I pulled out the whole board and soldered / hot aired the primary IDE connector on the back the board... just incase. However, the same two alternating boot errors occur.

Guess i need a new motherboard ?


[0] Message Index

[#] Next page

Go to full version