Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Mamehooker + iPac Ultimate/PACLed64  (Read 491 times)

0 Members and 1 Guest are viewing this topic.

Moleburt

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 17
  • Last login:October 14, 2022, 10:52:22 am
  • I want to build my own arcade controls!
Mamehooker + iPac Ultimate/PACLed64
« on: September 28, 2022, 10:00:18 am »
Wondering if anyone here has anyone here has any experience using the Ultimarc Ultimate I/O board and a PACLed64 board together with mamehooker? Iím not having much luck and wasnít sure where to ask. Iím trying to get some effects working with gun games (and eventually other games). Nothing Iíve tried has worked, Iím not sure if it is because I have 2 boards in order to control all my lights or what. I donít get any sort of error ping from windows, the most I have seen is ďultimarc devic #2 not detectedĒ or something of that sort. But both my devices show up in windows. Not really sure what to try next, any help would be appreciated!

*UPDATE*

Tested some more things and discovered a few things.

- If I just had the PACLED64 plugged in, it worked properly with mamehooker. But if both the PACLED64 and the Ultimate I/O board were plugged in neither worked.

- Fixed the above issue by flashing the Ultimate I/O board with the ID 2 firmware from the Ultimarc site. Doing this allowed them both to be plugged in and have the PACLED64 work properly, still nothing for the Ultimate I/O.

- Ultimate I/O just receives ďUltimarc Device Not FoundĒ regardless of what device number I select in the mamehooker test menu.

- I saw another post about the ultimate I/O from about a month ago l, they said the issue was fixed in the next version of mamehooker, 5.2, but I canít find a link to download.
« Last Edit: September 29, 2022, 08:39:58 am by Moleburt »

Moleburt

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 17
  • Last login:October 14, 2022, 10:52:22 am
  • I want to build my own arcade controls!
Re: Mamehooker + iPac Ultimate/PACLed64
« Reply #1 on: October 03, 2022, 12:29:49 pm »
Ended up moving most of my controls to my PACLed64 board, if/when 5.2 is available I will switch to that in order to allow the rest of my leds to work with mamehooker.

Headrush69

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 33
  • Last login:January 25, 2023, 07:12:41 pm
  • I have build my own arcade controls!
Re: Mamehooker + iPac Ultimate/PACLed64
« Reply #2 on: October 09, 2022, 05:35:00 pm »
Ended up moving most of my controls to my PACLed64 board, if/when 5.2 is available I will switch to that in order to allow the rest of my leds to work with mamehooker.
Same issue here, doesn't see my iPac Ultimate IO board.

Currently I have both LEDBlinky and MameHooker running and using LEDBlinky for LEDS/LAMPS works perfectly. Still getting around to hooking commands up for non-lamp outputs using MameHooker. Currently I'm getting a run-time 380 error everytime I try to add a command to a rom output.
So both MameHooker and MameOutTester from LedBLinky were seeing outputs at the same time, once I enabled actions in one they weren't available in the other.

Fixed runtime error with clean install of MameHooker.
« Last Edit: October 16, 2022, 09:30:43 am by Headrush69 »