Main > Driving & Racing Cabinets

Model 1 Link (Virtua Racing)

(1/6) > >>

Does anyone know how to link these games? I tried last night for a few hours but I couldn't get it to work.

On PC 1 I set the following in the mame.ini (PC 1 IP address =

mame.ini settings:
comm_localport 15111
comm_remoteport 15112
comm_framesync 0

On PC 2 I set the following in mame.ini (PC 2 IP address =
comm_localport 15112
comm_remoteport 15111
comm_framesync 0

Am I missing something? Also after messing around, I can no longer run Virtua Racing in widescreen, no matter what I set in the service menu, but that's another issue I can fix later :)


I got a 2 and 3 PC LAN working with this years ago, so I'm a bit rusty on the setup (my old PC I used to use as player 2 died ages back and the home network between my normal PC and Barcade cabinet seems to have inexplicably become broken, so they can't see each other anymore)

Anyway, I had a look in the MAME folder I still had for launching player 1 for the multi PC network. There's actually no config info for the network in my ini file, it's all in the batch file I use to launch the game. For Virtua Formula my P1 batch file looks like this:

--- Code: ---start /b mame64.exe vformula -w -comm_localport 15111 -comm_remoteport 15112 -comm_localhost -comm_remotehost
--- End code ---

With the IP address at the end belonging to my old PC (RIP)

I had a 4 Player single PC version of Virtua Racing that I started like this:

--- Code: ---start /b mame64.exe vr -w -cfg_directory cfg -nvram_directory nvram1 -comm_localport 15111 -comm_remoteport 15112 -comm_localhost -comm_remotehost
start /b mame64.exe vr -w -cfg_directory cfg2 -nvram_directory nvram2 -comm_localport 15112 -comm_remoteport 15113 -comm_localhost -comm_remotehost
start /b mame64.exe vr -w -cfg_directory cfg3 -nvram_directory nvram3 -comm_localport 15113 -comm_remoteport 15114 -comm_localhost -comm_remotehost
start /b mame64.exe vr -w -cfg_directory cfg4 -nvram_directory nvram4 -comm_localport 15114 -comm_remoteport 15111 -comm_localhost -comm_remotehost
--- End code ---

Bear in mind this was a version of MAME that's 5 years old now and probably hugely outdated (MAME 170b), so the setup process for multiplayer might've changed since then. Another thing to just bear in mind too is that you'll need a ZIP file called 'm1comm' in your ROMs folder in order to get the network working. Hope that helps.

Thanks, I think this is my issue "'m1comm'" I'll test tonight and report back.

From memory, for the same PC, the ports go in a ring, but the IP address stays the same. But for separate PC's, the IP's form the ring while the ports stay the same...?

Thanks, I tried setting the ports the same. Hangs on PC 2

Also I already had that comm file :(


[0] Message Index

[#] Next page

Go to full version