Software Support > GroovyMAME

DVI-I Port Shows Image ONLY When DP Has a Monitor???

(1/1)

springman:
Hi and thanks again for everything.

I have a Dell / AMD low-profile dual-port (DP & DVI-I) R5 240 card and it's driving me crazy.

The CRT is JVC DT-1710 tri-sync. It works well in Windows at 31kHz at the DVI-I port with a VGA adapter through a VGA-to-BNCx5 cable.

I follow the standard CRT Emudriver for HD5450 guide and pick Arcade tri-sync. No matter my LCD for setup is at DP or DVI-I, after enabling EDID emulation for the analog_0-VGA output and swapping in the JVC, the JVC reports out of range (not "no sync"). I assume the card now should output either 15kHz or 31kHz at the DVI-I port. What strange is that even I swap the LCD back on the DVI-I port the LCD has no image. I always have to fall back to the DP port. Plugging the LCD back to the DP port shows the 1080p desktop. And at the same time, the JVC would pick up the sync and displays the extended desktop as a second monitor at 31kHz

DP with LCD at 640x480; DVI-I with the JVC at 640x480 (have tried duplicate, extended desktop, made the JVC the main display), once I unplug the LCD, the JVC would go either out of range or no sync. Replugging the LCD at the DP port, the JVC goes back on.

And another finding: both Windows Device Manager and the CRT Emudriver installation reports that the display adapter / compatible devices is "AMD Radeon(TM) R5 240 (CRT Emudriver)", but in both VMMaker and Arcade OSD it is "AMD Radeon R7 200 Series" instead ...

I've tried everything for days and man ... I need a break. For now I can only resort to my older HD 8490.

Has anyone experience something similar? Is it an unsupported card somehow or something? Please help! Thanks!

Calamity:
springman,

If the monitor works well at 31 kHz, you don't need EDID emulation. Just install the modes that you need and go.

It sounds like when you unplug the LCD, Windows is restoring its last know configuration which is screwing your setup. You could avoid this probably by using Windows display manager in order to unplug the LCD, by first telling windows to only show desktop on the JVC, and then unplugging the LCD.

It could be an issue with monitor detection too, but I don't think it's that, otherwise you wouldn't be getting a picture at 31 kHz.

springman:

--- Quote from: Calamity on January 24, 2022, 11:45:18 am ---springman,

If the monitor works well at 31 kHz, you don't need EDID emulation. Just install the modes that you need and go.

It sounds like when you unplug the LCD, Windows is restoring its last know configuration which is screwing your setup. You could avoid this probably by using Windows display manager in order to unplug the LCD, by first telling windows to only show desktop on the JVC, and then unplugging the LCD.

It could be an issue with monitor detection too, but I don't think it's that, otherwise you wouldn't be getting a picture at 31 kHz.

--- End quote ---

Hi Calamity! Thanks for the reply!

By Windows Display Manager do you mean right-clicking the desktop and go to "Display settings"? I tried in there already by picking "Show only on 2". Once I pick it at the dropdown box the JVC goes out of range immediately!

I'm also trying to let the JVC be my only 31khz display as well but whatever I tried so far just doesn't wanna give me that ... I understand it's probably something about MS Windows but not the CRT Emudriver ... it'd be great if you know a way to make it work ...

Thank you so much!

springman:
I ... didn't rest after all ...

Whatever I do, whenever I don't have a display at the DP port, my JVC would just have an out of range signal.

With my another HD8490 LP dual-port (DP & DVI-I as well), with everything else being the same, the JVC works and boots as the only display at 31kHz.

So I guess it's either the R5 240 card, or Windows 10.

For now I can only stay with the HD8490, though the R5 240 is like 3 times more powerful (able to run Supermodel3 Spikeout FE at 640x480p60!)

Navigation

[0] Message Index

Go to full version