Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: I think I broke my CRT :  (Read 1499 times)

0 Members and 1 Guest are viewing this topic.

trick72

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 56
  • Last login:Today at 06:25:28 am
I think I broke my CRT :
« on: January 14, 2022, 04:07:12 am »
hi,
I Have a LG/Philips arcade 31khz CRT monitor. There are two labels on the tube: LG.PHILIPS M46QEF903X21 and Pentranic JVH 19" VGA PF Monitor +TS. It worked fine. It had two "pods" on the main board to adjust H-CEN and ABL (not sure what that does).
I was adjusting H-CEN with a small screwdriver and that put the picture more to the center LEFT/RIGHT.  Then I tried to adjust ABL thinking it would do the same for UP/DOWN but my screwdriver slipped off the pod while turning the pot and i touched "something". It could have been that I touched a GROUND wire which was nearby going around the tube...
The monitor imediately shut down completely. There is a LED on the board which goes from Orange to Green on normal working condition. That led turned orange and than again shut down.
I waited two hours with the monitor unplugged and tried again. Now I got a little further. The orange led stayed on longer and I hear a "thuck" sound I guess from the hi-power circuit turning on the tube. But after that thuck, the monitor shut down again. I then hear a "crisping" sound (which you usually hear when powering of the monitor)
I waited overnight and tried again but it's the same.
So any ideas what could have happened when I accidently touched something with my small screwdriver? I visually inspected the area around the POT but I don't see anything that looks damaged. I see that there is a cable labeled "ground" going to the tube. Maybe I touched that?
I added 2 images of the board, but it's still mounted in my cabinet...
Many thanks for any help

lilshawn

  • Trade Count: (+3)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 6903
  • Last login:August 13, 2022, 06:30:30 pm
  • I break stuff...then fix it...sometimes
Re: I think I broke my CRT :
« Reply #1 on: January 14, 2022, 08:43:56 pm »
ABL is Automatic beam level or automatic blanking level... it goes by a bunch of different names.

basically a CRT drive control circuit for automatically detecting and then limiting the CRT beam current when it is too large.

going to go ahead and say you've fried something. what? it's too hard to say right now. but it looks like the monitor has gone into shutdown (probably because whatever circuit that does the detection is shorted making it think you've gone over current.) probably a fried diode is all it is but where and what....you are gonna need to scrape up a schematic and start digging into it.

Robbbert

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 180
  • Last login:Yesterday at 08:03:04 am
Re: I think I broke my CRT :
« Reply #2 on: January 15, 2022, 06:39:19 pm »
Going by the fact that the OP blew it up because he had no idea what he was doing, doesn't bode well for actually fixing it.

Most monitors have front-panel controls for adjusting the height and width - why he felt the need to wield a screwdriver instead hasn't been explained.

If you are going to dive into it, at the very least get yourself the service manual and use it to learn what the adjustments affect, instead of doing random things.

Zebidee

  • Trade Count: (+8)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 2588
  • Last login:Today at 04:18:05 am
Re: I think I broke my CRT :
« Reply #3 on: January 15, 2022, 07:59:02 pm »
A schematic would help a lot. However, there is a lot you can do, even without a schematic. There is also a lot you can simply check without removing parts.

First, check the ABL pot for ohms with DMM to make sure it is OK. Reset it to original position (I hope you marked it before moving). You don't normally want to adjust this. It is probably set with reference to a service manual and a multimeter or even an oscilloscope. It may have taken a little while for the circuit to fail after you adjusted this, so the good news is it may have had nothing to do with your screwdriver. Except for when you used it to turn the pot :D

Problem is going to be the SMPS power supply. So, mostly the areas you showed in your pics plus a bit more around the flyback etc. Then, if you can find the optocoupler (which sits across the hot/cold sides, provides isolated feedback and initiates shutdown if needed), that and the parts in between would be most of the power supply apart from some local DC voltage regulators.

So, check all the diodes in that power supply area with your DMM (diode setting ofc). Black on cathode, red on anode ends. Mostly you get 300-900mV. Swap leads you should get OL or high resistance, maybe similar to first reading if there are other diodes/paths in the circuit. If you get dead shorts or low resistances/OL both ways then it may be blown (when in circuit you can get weird readings, remove a leg to double-check). Diodes can blow with no apparent damage.

Start with the big power diodes near the primary transformer, the big yellow one, on the COLD side. You can blow the main B+ power diode and still have standby power (the LED lights). Check the smaller diodes glass too, especially around the flyback and the optocoupler and even the opto itself, as it provides power feedback/shutdown and is connected to the B+. Some diodes may be designed to blow to protect the circuit.

Check resistors, ohms. Again, some may be designed to blow and protect the circuit, and if you are lucky that is all. Resistor failure may be obvious, burn marks, heat scarring on PCB, something to look for. Mostly you are looking for dead shorts or values that are way off. Be aware that some large high-wattage resistors in power supply may have very low ohms.

Check all transistors in the area, big and small. Use diode setting on DMM. Check HOT. What the YT videos usually won't tell you is that it is normal to see a dead short between base and emitter while in circuit, but you should have normal B-C and C-E readings. A failed HOT may mean you get false negatives when checking the main power diodes, and vice-versa, but for double-checking it is easier to remove a diode leg than to remove the HOT :)

Always remember that some very high voltages are used in these areas, Always exercise extreme caution, especially live, even if you know what you are doing. Consider avoiding otherwise. Understand where the grounds are so you don't get zapped. Isolation transformer recommended for safety.

See, simple :D
« Last Edit: January 15, 2022, 08:01:52 pm by Zebidee »
Check out my completed projects!


trick72

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 56
  • Last login:Today at 06:25:28 am
Re: I think I broke my CRT :
« Reply #4 on: January 16, 2022, 04:19:24 am »

See, simple :D

Thanks for your extensive explanation... Simple it is not going to be  ;). I'm afraid I did not mark the position of the ABL Pot. I did not know you could damage a complete CRT by turning a pot. I had no other front panel controls or other means to change the horizontal / vertical position and size on this monitor so I thought that it was via these POTS.

So I guess because I don't have the position of the ABL where it should have been, and no schematics or service manual, it's useless to try to fix the circuit itself (If I could, which seams not easy at all for a newbie in CRT) because it will break again the moment I put it on if the ABL is not in the correct position ... So Sad... well, lesson definitely learned the hard way.

Zebidee

  • Trade Count: (+8)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 2588
  • Last login:Today at 04:18:05 am
Re: I think I broke my CRT :
« Reply #5 on: January 16, 2022, 04:57:16 am »
Find someone local that knows CRTs - you might get lucky and they find something simple. I've never had to set an ABL pot, or even seen one before, but I don't work on VGA monitors either (SMPS power supplies for CRTs all basically the same though). ABL is something I normally see as a flyback pin and on the schematics, with something like what lilshawn said and "leave this alone" written there, so usually I just do that. There are ways like using a variac to raise voltage slowly, and you could find a schematic or search the might Internet for further clues as to how that pot should be set. Somebody has done it before.

Good practice is to always use a Sharpie or white-out or similar to mark the original positions of pots before you move them, at least if you aren't sure what they'll do. Best would be to take an ohms measurement across the main terminals (while powered down please :D ).
Check out my completed projects!


Robbbert

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 180
  • Last login:Yesterday at 08:03:04 am
Re: I think I broke my CRT :
« Reply #6 on: January 16, 2022, 07:44:18 am »
Most adjustable circuits are designed so that the centre position will be close to the optimal setting, so you could set the ABL pot to the middle of its range. If the circuit hasn't been damaged, it should work at that point, even if not exactly correct.

Next, if you did hit that black post, you might have fractured its soldering to the PCB. Check that it is secure and not wobbly. Lastly, it appears to be some kind of push-on connector, so give it a twist to remove any internal corrosion.

Finally you can turn it on and see if you made any difference (good or bad).

One of the unfortunate things about power supplies these days is that a tiny fault can cause a chain reaction of all kinds of expensive parts all blowing up. But I guess you'll never find out if that happened.

trick72

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 56
  • Last login:Today at 06:25:28 am
Re: I think I broke my CRT :
« Reply #7 on: January 16, 2022, 09:09:30 am »
Thanks guys,
One thing I found today was that if I removed a certain plug from the NECK BOARD of the tube (a cable that is going from the neck board to the main chassis board), than the board seems to work again. Power stays on fine, the LED on the chassis board even goes GREEN when it "detects" the VGA signal when I power on my PC ! So it detects that it receives a picture that is in sync (the led goes from RED to GREEN the moment my PC sends a correct VGA signal). Also the tube itself powers up, although I do not have any neck glow so I don't see any image, probably because that cable is unplugged. The screen itself stays black.
Not sure if this can be of any help, and I already placed a local advertisement for finding a local CRT technician, but I thought I would share this anyway...
I attached an image of the cable I disconnected... it's a wide cable with small wires so I don't think there is any high voltage going thru this...
Thanks.


Mike A

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5663
  • Last login:Today at 04:45:10 am
  • This plan is foolproof
Re: I think I broke my CRT :
« Reply #8 on: January 16, 2022, 09:29:22 am »
Stop poking around blindly. You will wreck the monitor and make it more difficult to repair.

Zebidee

  • Trade Count: (+8)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 2588
  • Last login:Today at 04:18:05 am
Re: I think I broke my CRT :
« Reply #9 on: January 16, 2022, 09:36:03 am »
That black wire you think you might have touched is just the ground for the screen voltage (is likely attached to the neck yes?).

Make sure the male end is soldered in properly (no cracks etc) and that you get proper connectivity to ground at both ends. It may just be that the screen voltage isnít getting grounded properly. Maybe your touch was just hard enough to knock it loose.
Check out my completed projects!