Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: AMI Rowe R-93 CD/Record Jukebox. Pioneer PD-M400 6-disc player. HELP!!!!  (Read 1719 times)

0 Members and 1 Guest are viewing this topic.

RoweDJ

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 1
  • Last login:March 07, 2022, 05:45:05 pm
I have a Rowe R-93 CD/45 combo jukebox. The records play fine. But, when I got it, the CD player would rotate through the 6 discs at startup, but none would play. I found the laser lens was missing. A local repair center took an identical CD player and swapped out the entire CD unit, inserting it into my player since the wires that connect to the jukebox were already soldered onto the motherboard of the Pioneer player. The CD player now plays great when operated manually, I tested it according to instructions in the Rowe manual by selecting a record, then lifting the tonearm up and away to keep the record spinning and the amp activated. But when I try to select a song through the jukebox, it's not recognized. Nothing happens. The switch is on Video/Data, "not" record. All wires are plugged in correctly and in good shape. When I select a record from the keypad, in addition to the record playing, the song on CD 1, track 1 starts playing also. I tried to initialize (or MAP) the CD's according to the manual, but nothing happens when I set the box to Service mode and enter "777", then switch back to play mode. The Pioneer doesn't even cycle through the 6 discs in the CD cartridge. I've tried to contact everyone I could find on the Internet for an answer, but so far, no luck. The R-92 CD/45 Combo Supplement manual (Part # 21896902) Section 4 "Troubleshooting" says: 1. The CCC may be defective, 2. The harness between the CD player and the CCC may be unplugged or defective, 3. One of the CD discs did not initialize, 4. The CD player is defective. I've tried various CD's in the player and it doesn't appear to make a difference.
I'm in the Lancaster, PA area. Any help or suggestions would be GREATLY appreciated! I'm totally lost on this one!!! I've been told there are very few people around today who worked on these combo jukeboxes back in the late 80's.
Thank you!

Update:  I finally got the CD part working in my combo Jukebox!!!
A friend, who also repairs jukeboxes was at a warehouse in Maryland where he picks up parts and happened to see a Pioneer 6 disc player that had the same plug as my player and picked it up.
It’s a different Pioneer model than mine, but we plugged it in, put the jukebox in “Service” and entered the “777” code.
WE HEARD MOVEMENT!!!! Yes, it was actually formatting the jukebox for the discs that were in the player.
After it completed the cycle we tried it and…IT WORKED!!!!

After my friend left, I continued to enter CD songs at random and two of the songs on one disc stuck, and one song on another disc.
However, I attribute it to either of two things….
1.   The tracks on the cd’s were bad. These were the discs that were in the jukebox when I got it. The tracks before and after the bad tracks played fine.
2.   The bass in the speakers made the tracks stick. My old CD player had springs on the bottom to eliminate vibration, the new player doesn’t. Since I have the jukebox on a cement floor in my garage, I didn’t see the need to add the springs…unless Bigfoot comes to visit!!!
I’m going to add 6 of my favorite cd’s to the player, format the machine, and see how that works.
So, the problem all along was with my CD player, even though it works fine without being hooked into the jukebox.
My guess is something crazy with the wiring on the CD player’s motherboard.

I hope this information helps someone else with a similar issue.
« Last Edit: March 07, 2022, 05:37:46 pm by RoweDJ »