Main > Raspberry Pi & Dev Board

Buttons Not Registering in MAME


I've been trying to get my bartop setup for a while now and just keep hitting walls getting my buttons to work. My setup:
RPI 3 with fresh install of Retropie. 4 way joystick + 3 action buttons + 2 start buttons (P1 and P2) + 3 admin buttons. Joy and buttons running through a zero delay encoder.

I was able to configure my buttons just fine on the fresh install. When I launched a game, I couldn't get the coin/credit to work. First I tried pressing Select (one of my admin buttons)...nothing. Next I hit tab to go into the config menu, scrolled down to Coin 1, pressed Enter, then I pressed my Coin 1 arcade button and it didn't do anything...I tried rewiring the button to another open slot on the zero delay encoder and still nothing. I was able to change the Coin 1 input using a random button on my keyboard...just not by pressing the Coin 1 arcade button. I know the button/switch physically works because I was able to set it up on the initial retropie screen. Not sure what to try next. Appreciate any tips.


[0] Message Index

Go to full version