Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Recently my Megatouch XL upright screen has to be on for over an hour to look OK  (Read 685 times)

0 Members and 1 Guest are viewing this topic.

DaddyLongLegs

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 257
  • Last login:October 11, 2021, 02:23:36 pm
I suddenly have a weird issue come up with my MegaTouch XL upright cabinet. I've had it for about 10 years and this just started a few months ago.

When I turn it on, the picture is very dark. I open the back up and adjust the CRT pot (the one on the back of the monitor right next to the focus one) so the brightness looks good, and it works and looks good.  But then like an hour later the picture is way too bright. I was going crazy asking myself how is the knob turning by itself.

So I called a CRT repair technician in my area (yes believe it or not, there is one) who came by and replaced some caps on it a few years back when the image was super wobbly. He came and said he could not find anything wrong with it, and he tested every single cap and they were fine.

So the other day I turned it on and it was very dark as usual, so I decided to just leave it on without adjusting the pot on the back. Sure enough about an hour later, and the image looks great.

Does anybody know what could be causing this? The power supply is brand new (the one that powers the motherboard and stuff) so it's not that. Is there something fixable to get rid of this issue? Or something I should be replacing?

It kind of puts a damper on having friends come over who suddenly want to play it and we have to wait an hour for the picture to be acceptable, so any recommendations would be greatly appreciated.

lilshawn

  • Moderator
  • Trade Count: (+3)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6741
  • Last login:Yesterday at 07:41:15 pm
  • I break stuff...then fix it...sometimes
i would try your question over to monitor/video sub and see if someone there knows. unfortunately the XL system is not very popular, but uses a standard enough monitor someone might know.

pbj

  • Trade Count: (+4)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 9997
  • Last login:Yesterday at 11:22:48 am
  • Obey.
    • The Chris Burke Band
Unplug and replug both ends of the video connection cable a few times?

 :dunno
I aspire to be involved in the classic gaming community.