Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: New versions of groovymame dont works +0.27 and dont save ini  (Read 1492 times)

0 Members and 1 Guest are viewing this topic.

Sendinoportillo

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 5
  • Last login:September 06, 2021, 10:06:31 am
  • I want to build my own arcade controls!
New versions of groovymame dont works +0.27 and dont save ini
« on: August 22, 2021, 02:32:05 pm »
Hello everyone and thank you very much to all of you for all the work you do, especially the creators of Groobymame and the crtemudriver.
I have an Ati HD6870 and Ati Hd5770, which I have used doing all the steps to have a 15Hz signal on the TV, getting it.
The problem I have is that once the drivers are installed, even before taking the 15Hz signal, Groobymame does not work from version 0.27, and version 0.27 and earlier if they work, taking the original resolutions, but leaving some potions of video such as bilinear filtering, enforce aspect ratio, synchronized refresh and wait vertical sync.
If I edit these options and save them when I exit mame, they appear activated again in video d3d, the only thing I can change and it appears saved is the Video Mode.
if i uninstall crtemudrivers drivers , open all grooby mame and save the settings, I can play 15Hz with 640x480 resolution.
I have tried on 2 different computers and the same thing happened to me, I don't know if it is a bug in the drivers with those cards or what the problem will be, but I would appreciate any help because I am going crazy, thank you very much.
This is what I get when I run groobymame with the crtemudriver drivers installed, with cmd

Exception at EIP=0000000000000000 (): ACCESS VIOLATION
While attempting to write memory at 0000000000000000
-----------------------------------------------------
RAX=000000000000003c RBX=00000088c9cf6f70 RCX=0000000000000000 RDX=0000000000000000
RSI=000001d34ff0d400 RDI=00007ff7b9da6783 RBP=00000088c9cf6ed0 RSP=00000088c9cf6d28
 R8=0000000000000000  R9=00000088c9cf6d60 R10=0000000000000000 R11=00007ff7b9da678a
R12=000001d34ff0ee70 R13=00000088c9cf6d70 R14=0000000000000000 R15=00000088c9cf6f70
-----------------------------------------------------
Stack crawl:
  00000088c9cf6d20: 0000000000000000 ()
  00000088c9cf6e70: 00007ff7b44d29f0 (netlist::devices::nld_74166::~nld_74166()+0x0920)
  00000088c9cf7060: 00007ff7b3edf8e5 (non-virtual thunk to superfx_device::~superfx_device()+0x0115)
  00000088c9cf8ba0: 00007ff7b3ee0100 (non-virtual thunk to superfx_device::~superfx_device()+0x0120)
  00000088c9cf8f00: 00007ff7b155e67b (std::unique_ptr<device_t, std::default_delete<device_t> > emu::detail::device_type_impl_base::create_device<kc_m006_device>(emu::detail::device_type_impl_base const&, machine_config const&, char const*, device_t*, unsigned int)+0x005b)
  00000088c9cf8fd0: 00007ff7b1570ea9 (v1050_keyboard_device::device_add_mconfig(machine_config&)+0x02c9)
  00000088c9cf9040: 00007ff7b1574af6 (v1050_keyboard_device::~v1050_keyboard_device()+0x00a6)
  00000088c9cf91a0: 00007ff7b1559de5 (kc_m032_device::write(unsigned int, unsigned char)+0x0045)
  00000088c9cf9480: 00007ff7adf4abea (driver_mk83::{lambda(machine_config&, device_t&)#1}::_FUN(machine_config, device_t)+0x00aa)
  00000088c9cf95b0: 00007ff7ae1b6127 (gfx_element::prio_transtable(bitmap_ind16&, rectangle const&, unsigned int, unsigned int, int, int, int, int, bitmap_ind8&, unsigned int, unsigned char const*)+0x01b7)
  00000088c9cf9710: 00007ff7ae1b8581 (gfx_element::prio_zoom_opaque(bitmap_rgb32&, rectangle const&, unsigned int, unsigned int, int, int, int, int, unsigned int, unsigned int, bitmap_ind8&, unsigned int)+0x00f1)
  00000088c9cfef30: 00007ff7b1567bdb (non-virtual thunk to tvc_hbf_device::write(unsigned int, unsigned char)+0x00cb)
  00000088c9cff310: 00007ff7b3b7df9f (sol::usertype_traits<sol::detail::tagged<core_options::entry, sol::no_construction const&> >::metatable[abi:cxx11]()+0x00ff)
  00000088c9cff5d0: 00007ff7b3b7e5ad (std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const& sol::detail::demangle<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const& (core_options::entry::*)() noexcept const>()+0x000d)
  00000088c9cff630: 00007ff7b1564e69 (device_single_card_slot_interface<device_tvcexp_interface>::interface_pre_start()+0x00d9)
  00000088c9cffb50: 00007ff7b4b78399 (_GLOBAL__sub_I__ZN13norautp_state11video_startEv+0x0129)
  00000088c9cffc20: 00007ff7a9e313b1 (__tmainCRTStartup+0x0221)
  00000088c9cffc50: 00007ff7a9e314e6 (mainCRTStartup+0x0006)


thanks so much

B2K24

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 205
  • Last login:October 12, 2021, 10:59:56 am
Re: New versions of groovymame dont works +0.27 and dont save ini
« Reply #1 on: August 23, 2021, 09:45:31 am »
I just went through this problem.

The latest MAME & GM requires you to have installed the lastest version of crt_emudriver_&_tools_2.0_beta_15_16.2.1_W.7.8.10-64

If your driver is not updated you get crash with stack crawl so boot into safe mode, remove driver, and install latest version then GM runs fine.

Sendinoportillo

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 5
  • Last login:September 06, 2021, 10:06:31 am
  • I want to build my own arcade controls!
Re: New versions of groovymame dont works +0.27 and dont save ini
« Reply #2 on: August 23, 2021, 11:08:03 am »
I have got an HD5770 and downloaded - Download CRT Emudriver & CRT Tools 2.0 beta 15 (Catalyst 12.6) for Windows 7/8/10 64-bits
I just  installed - Download CRT Emudriver & CRT Tools 2.0 beta 15 (Crimson 16.2.1 non-GCN* cards) for Windows 7/8/10 64-bits and works fine :cheers: you give me the light... I was convinced that they were the previous drivers by catalyst name.
Now I try change video options, turn off bilineaar filtering and save it into mame menu and got this error " no driver loaded(__empty).MAME 0.234 (LLP64) caught unhandled 25options_warning_exception exception:illegalboolean value for keepaspect "48"; and I canīt save any options of video.( is this a bug in groovy mame ), thanks so much...
« Last Edit: August 23, 2021, 11:12:40 am by Sendinoportillo »

B2K24

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 205
  • Last login:October 12, 2021, 10:59:56 am
Re: New versions of groovymame dont works +0.27 and dont save ini
« Reply #3 on: August 23, 2021, 08:16:56 pm »
I think your error is because you didn't edit Video Mode Maker then generate and install the modes. In the edit settings you can use super resolutions and point it to your GM folder so it puts it in mame.ini

See this guide and you should be set. I did a complete reformat and had no problems using latest GM. You just gotta set a couple options right then off you go.

https://geedorah.com/eiusdemmodi/forum/viewtopic.php?id=301

Sendinoportillo

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 5
  • Last login:September 06, 2021, 10:06:31 am
  • I want to build my own arcade controls!
Re: New versions of groovymame dont works +0.27 and dont save ini
« Reply #4 on: August 24, 2021, 09:43:34 am »
thanks B2K24, I have made the tutorial with w7 and w10, ever I open mamegroovy and try save configuration got the same error screen

" Caught unhandled 25 options_warning_exception exception: Illegal boolean value for keepaspect "48"; reverting to 1 "

Have any idea? Thanks

... with old drivers FlyCast emulator works fine, now with this lost the sync..  :banghead:
« Last Edit: August 24, 2021, 09:55:16 am by Sendinoportillo »

Sendinoportillo

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 5
  • Last login:September 06, 2021, 10:06:31 am
  • I want to build my own arcade controls!
Re: New versions of groovymame dont works +0.27 and dont save ini
« Reply #5 on: August 24, 2021, 11:49:32 am »
Whit CRT Emudriver & CRT Tools 2.0 beta 15 (Catalyst 12.6) for Windows 7/8/10 64-bits, I can open grooby mame 0.225 but ever try so save video options say " configuration saved " play game and do correct, exit mamegrooby start again and video options are same before save it....

https://ibb.co/6BRX8Hx

why do not save? I have tray edit mame.ini and nothing.

thanks
« Last Edit: August 24, 2021, 11:52:38 am by Sendinoportillo »

B2K24

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 205
  • Last login:October 12, 2021, 10:59:56 am
Re: New versions of groovymame dont works +0.27 and dont save ini
« Reply #6 on: August 24, 2021, 11:57:33 am »
Sorry, I don't know. I've never needed to change those options so i don't touch them. I just follow the tutorial and let VMM transfer settings to mame.ini using super resolutions and whatever it defaults works perfect on my setup.

Sendinoportillo

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 5
  • Last login:September 06, 2021, 10:06:31 am
  • I want to build my own arcade controls!
Re: New versions of groovymame dont works +0.27 and dont save ini
« Reply #7 on: August 24, 2021, 12:26:03 pm »
with that option fps in golden axe are not 100% stables ( i5 4590 )....

alex2005

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 113
  • Last login:October 19, 2021, 12:38:59 pm
  • I want to build my own arcade controls!
Re: New versions of groovymame dont works +0.27 and dont save ini
« Reply #8 on: September 07, 2021, 07:23:04 am »
I have a similar issue where in Video Options for Screen #0 would not save for games with multiple monitors like Warrior Blade (warriorb) and Ninja Warrriors (ninjaw)

For example if I enable Maintain Aspect Ratio and then I exit the game, on the next start it will still be set to disabled (as default). Same happens if I select Dual / Gapless screens on these options. Tried with writeconfig enabled on the mame.ini but seems the config would not apply correctly and always needs to be adjusted manually.

This worked fine until mame 0.233 but seems not to work on 0.234 nor 0.235, or at least I haven't been able to find out why nor how to fix it. A specific ini file for these games also did not help :(

EDIT: somehow when I post here I often manage to solve the issues pretty quick :)
It seems it was an issue with the global configuration. I had to switch off "enforced aspect ratio" and then save the config from the global configuration. this created a specific ini for the affected game. Somehow I never had a need to do this until 0.233, so I guess something changed in the configuration priorities.
Anyhow, solved, just wanted to share in case someone goes through the same issue :)
« Last Edit: September 11, 2021, 06:07:31 am by alex2005 »