Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Rowe Ami Title Page problem  (Read 3389 times)

0 Members and 1 Guest are viewing this topic.

Keats

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 9
  • Last login:August 12, 2021, 03:59:36 pm
  • I want to build my own arcade controls!
Rowe Ami Title Page problem
« on: August 06, 2021, 02:04:13 pm »
6 Aug 21
Rowe Ami CD-100-G "Laser Star" VI.

Print Reference "Juke Box Manuals.Com" Section 6-12. Title Page Assembly Adjustments.

I have everything up and running like it should except the title pages. I did a restore to factory defaults and re initialized all the CD's and reset it for free play including Albums.
I've read the manual time and again so I have a general idea of how things work.

For some reason the title pages are not functioning as they should. If I press one of the buttons to move the pages up or down, sometimes they work, but more often it will flip more than one page with a single brief button push. Sometimes it will not flip the last page down to reveal the available music choices on the top title page.
I can rotate the Title Page "Knob" under the title page assembly and the pages will flip. So they are not stuck in place.

I read the manual and it tells me to remove the title page assembly, turn it on end Remove a cover and the light block cover and readjust the crank.

What I'd like to see is a video or even photos of this repair before I try it. The diagrams on the manual are good but they are not photos, just drawings. They show a cam on the motor end but there are no drawings for the non motor end.

Has anyone ever done this repair and if so, are there videos or photos available to show what I'm getting into?

Any help will be greatly appreciated. Especially photos or a video or a link to either of them.

Thanks,

Keats
Arizona.