Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Megatouch Ion Aurora Power On Issue, Pulsing  (Read 5542 times)

0 Members and 1 Guest are viewing this topic.

arcadezz

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 18
  • Last login:May 24, 2022, 03:25:53 pm
Megatouch Ion Aurora Power On Issue, Pulsing
« on: May 26, 2021, 08:44:15 am »
Hello, has anyone experienced their Aurora pulsing after turning it on? All the LED's blink on and off and the fans are pulsing on and off.....the unit doesnt actually turn off completely and there is no video or boot sounds. I uploaded a video to show the issue better.



Thanks for any help.

mahkeymike

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 698
  • Last login:Yesterday at 12:45:13 pm
Re: Megatouch Ion Aurora Power On Issue, Pulsing
« Reply #1 on: May 26, 2021, 07:38:09 pm »
Sounds like bad psu

lilshawn

  • Moderator
  • Trade Count: (+3)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6864
  • Last login:May 27, 2022, 11:04:28 pm
  • I break stuff...then fix it...sometimes
Re: Megatouch Ion Aurora Power On Issue, Pulsing
« Reply #2 on: May 30, 2021, 10:29:32 pm »
check for coins under/on the motherboard.

otherwise, bad PSU

Spank

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 28
  • Last login:Yesterday at 02:52:24 pm
  • I like to help out.
Re: Megatouch Ion Aurora Power On Issue, Pulsing
« Reply #3 on: June 07, 2021, 07:16:49 am »
Power supply, make sure it isn't set to 220v.

arcadezz

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 18
  • Last login:May 24, 2022, 03:25:53 pm
Re: Megatouch Ion Aurora Power On Issue, Pulsing
« Reply #4 on: June 13, 2021, 09:26:13 am »
I switched out the power supply and same issue. I also removed the motherboard and powered it on with just the monitor attached and it does the same thing.....the fan making the sound is the cpu fan going on and off. Any other suggestions? Thanks.

mahkeymike

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 698
  • Last login:Yesterday at 12:45:13 pm
Re: Megatouch Ion Aurora Power On Issue, Pulsing
« Reply #5 on: June 14, 2021, 09:46:39 pm »
Something is drawing too much power, usually indicating some type of short. Ive seen Hard drives cause this, but you said you only had the monitor attached. Try a different monitor? If it still does it, your Motherboard must be bad. Check the Caps, do any of them visually look like that are swelling up or leaking?

arcadezz

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 18
  • Last login:May 24, 2022, 03:25:53 pm
Re: Megatouch Ion Aurora Power On Issue, Pulsing
« Reply #6 on: July 07, 2021, 09:48:20 am »
Thanks for the information....I ended up replacing the motherboard and now all good!