Main > Lightguns

Aimtrak Ligh Gun losing its recoil

(1/2) > >>

magick81:
Hi all,
Am new to the scene to please forgive any noobishness I may display.

For Christmas I treated myself to the Aimtrak Light Gun. Unfortunately i didn't have much luck using it with my rpi4 Retropie.
So I switched to my PC and have been using it with MAME and Teknoparrot and I have been having an absolute blast of a good time.

But lately my gun isn't performing as it did when it was brand new. I noticed the recoil had stopped working. I have tried with different games on MAME and Teknoparrot. Even the calibration app, no recoil. Sometimes if I hold the gun at an angle I can get the recoil going again, and provided i keep it at that angle i can aim around that general area and keep the recoil.

I am no expert but it sounds like maybe some faulty or bad wiring. Can anyone tell me which wires to check? I'll have to see if i can find my multimeter in the meantime.

magick81:
Wow. Nobody has any ideas?  :( :o ??? Guess I'll have to ask the manufacturer instead

Foxhole:
Sounds like a wiring issue to me.
Probably the psu wire, try playing around with it and see if there's any difference.
If there is a change when you mess with the psu wire, then you'll probably be better off either replacing it or just finding the weak spot and fixing that.

clhug:
I've been wanting to post this question for a while, but did just now do some troubleshooting and got it working again on my own.  (Saw your question and was going to post that I also needed to help but decided to finally go look at it myself before posting, and just got lucky that I got it to work.)

I've had dual AimTracks w/ recoil using with MAME for about 5 or 6 years now.  The recoil worked great when I first got it, but I noticed about 2 years ago that the recoil only fired maybe 1/4 of the time, and half the time it did fire it was very weak.  The gun itself (the "lightgun" piece) still worked fine, it was only the recoil.

This happened with both guns.

I went into the AimTrack config software and tweaked the Recoil slider, reducing it some, and the recoil began working reliably again.  I noticed I had the Recoil slider all the way to the right.  I ended up lowering the setting.  With one gun I only needed to lower it by about 1/4 (so it was set AT about 3/4), but the other gun I needed to reduce down to a little under half.

Oddly, I can't find any mention of this Recoil slider in any of Ultimarc's documentation.  I guessed it was recoil force (like an internal voltage or current limiter to affect how hard the recoil "hits").  But I don't know.

Also of note, the Test button for the Recoil in the config software didn't fire the recoil either, after I got the slider adjusted to "fix" it while pulling the trigger on the gun itself, so I wouldn't necessarily trust that Test button.

I also swapped power supplies to see if affected what setting I needed on each gun, but it did not.

What I wonder is if the solenoid is getting weaker after a few years of use, but that is also only a guess.

Trnzaddict:
Iím not sure the solenoids in the Aimtraks are very strong. I read here You canít even use them for rapid fire games like T2 or Rev X for more than like 15 minutes if not the solenoid will overheat and break permanently.

Thatís unbelievably weak.

Navigation

[0] Message Index

[#] Next page

Go to full version