Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: ION-EVO not booting  (Read 1074 times)

0 Members and 1 Guest are viewing this topic.

Randy0777

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:May 26, 2020, 01:57:47 am
  • I want to build my own arcade controls!
ION-EVO not booting
« on: May 20, 2020, 12:48:58 am »
Hi, need some help please...

A little background on the game. I picked it up at a flea market, and you could see that someone tried to pry it open...with no luck.
I already had two at home, so I figured for parts. Jump ahead 7 years (I've been busy :) ) Since being stuck at home, I'm running out of things to do, so time to work on the game again.

Looked up everything, and looks like they broke the board loose from the mounting screws. Made sure nothing was touching, powered it up, D-sub cable error. Checked the battery, 2.8V so replaced it. Jump the pins on the P/S and board comes to life (Lights only), still D-sub error.

Hooked the monitor up to a PC and it was good. Pulled the MB out, no obvious caps blown . Its the ASUS K8N-VM board, my other two are the purple boards.

So, I was thinking about replacing the board and CPU with a upgraded one, if thats possible ?
I figured it was either the MB or CPU.

Any suggestions would help. Thank you.

PS they never did get in it, still 3$ in BV  :banghead:

mahkeymike

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 658
  • Last login:Yesterday at 01:06:57 pm
Re: ION-EVO not booting
« Reply #1 on: May 20, 2020, 08:54:27 am »
Bad onboard video chip. Needs new mobo.

Randy0777

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:May 26, 2020, 01:57:47 am
  • I want to build my own arcade controls!
Re: ION-EVO not booting
« Reply #2 on: May 21, 2020, 02:10:26 am »
Thank you for the reply.
From reading , it looks like the D945GCLF2D MB is a direct fit ??? Is this still the best option for a replacement ? I see a few on Ebay, with the CPU.
Is there anything special I should look for?
 Looking at the specs for that MB, it says use DDR2 400/533, 2GB max.g Does it matter which size I get, as long as its 512 or higher?

justtaint

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 66
  • Last login:April 07, 2021, 05:42:52 pm
Re: ION-EVO not booting
« Reply #3 on: May 21, 2020, 06:35:32 pm »
As I read in another thread, From Lilshawn "either the asus or if you have a post 2009 software install, the D945GCLF or D945GCLF2 (first year implemented) it runs cooler and produces less heat overall.

either way, you are looking at doing some mods to get it in there."

http://forum.arcadecontrols.com/index.php/topic,130306.40.html

I went with the Asus A7N8X-VM in my Ion EVO because someone on Craigslist was selling mobo, cpu, ram combos for dirt cheap.
I had to trim 3 of the fins on the Northbridge heat sink to get the I/O board to fit, took all of 30 seconds with a dremel and a cutting disc.
« Last Edit: May 21, 2020, 06:38:02 pm by justtaint »

Randy0777

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • Last login:May 26, 2020, 01:57:47 am
  • I want to build my own arcade controls!
Re: ION-EVO not booting
« Reply #4 on: May 25, 2020, 10:43:20 pm »
Jumping the P/S has helped quite a bit previously, however, this time I had to jump the MB. All is good  :applaud: Thanks for the replies.

lilshawn

  • Moderator
  • Trade Count: (+3)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6674
  • Last login:Yesterday at 07:41:49 pm
  • I break stuff...then fix it...sometimes
Re: ION-EVO not booting
« Reply #5 on: May 26, 2020, 01:05:17 am »
looks great man!  :cheers:

Ken Layton

  • Guru
  • Trade Count: (0)
  • Full Member
  • ****
  • Offline Offline
  • Posts: 7027
  • Last login:Today at 10:39:18 am
  • Technician
Re: ION-EVO not booting
« Reply #6 on: May 26, 2020, 10:46:36 am »
Merit Field Bulletin 54 addresses power on problems:

http://www.meritgames.com/Support_Center/Bulletins/PDF/FLDBLL54.pdf

I had to get that harness from Betson to get an Ion Evo that came in with a "no power up" problem to power on. The harness completely replaces one that came with the machine. It has redundent grounds so the machine will power on consistently every time.

See this thread too:

http://forum.arcadecontrols.com/index.php/topic,149849.0.html
« Last Edit: May 26, 2020, 10:48:38 am by Ken Layton »