Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns Arcade1Up --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Aimtrak and Steamlink - Shaky cursor?  (Read 412 times)

0 Members and 1 Guest are viewing this topic.

dammit57

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 2
  • Last login:February 02, 2020, 07:28:51 pm
  • I want to build my own arcade controls!
Aimtrak and Steamlink - Shaky cursor?
« on: December 11, 2019, 06:11:57 pm »
Hi

First off, hello everyone, great forum you have here. I've been reading allot of posts here recently and getting lots of great info, thanks. I've just joined up with the hope that maybe someone could offer some advice..

I've recently been getting an emulation setup together where I use a Valve Steamlink plugged into my large loungeroom television, on which I stream games and emulators across wired Ethernet from my PC which is in another room of the house. (It's an older 2010 machine, running Windows 7 64bit, though all the games seem to run fine).

I've been trying to get my Aimtrak Lightgun to work with the Steamlink, but am having no luck unfortunately. Whenever I plug the sensor bar and gun into the USB ports on the Steamlink, the mouse cursor starts jumping all around the screen. It seems to have some relation to the position I'm holding the gun, like some of the positional information is getting through, though it's as if the pointer has had it's sensitivity turned way up and there's extreme shake on the cursor.
Plugged straight into my PC (No Streamlink) the Aimtrak works great and I'm able to load games through Steam (As is required by the Steamlink) and play them fine. It's just when plugged into the Steamlink, and streaming to my television I have the issue.

On the Steamlink i've turned the mouse sensitivity all the way down and it hasn't helped.

I've tried a standard wireless USB mouse on the Steamlink and the cursor movement is fine.

I've also tried plugging the Aimtrak and Sensor bar into a powered USB hub, then into the Steamlink, but the cursor still shakes erratically.

I just wanted to ask if anyone here has experimented with a similar setup, or experienced a similar shaky cursor with their Aimtrak + Steamlink?
I've heard mention of a USB streaming App for the Steamlink called "Virtualhere", which enables various USB controllers, but I'm not sure if this would help with the Aimtrak.

Any help or advice would be appreciated. Thanks for your time :)

Titchgamer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 3607
  • Last login:Today at 10:25:21 am
  • I have a gaming addiction.....
Re: Aimtrak and Steamlink - Shaky cursor?
« Reply #1 on: December 12, 2019, 02:47:52 am »
Have you tried opening the aim trak utility and seeing what its doing in the diagnostics?

Sorry I dont have any specific advice having never done this myself.

But my 2 initial guesses would be 1) Extreme lag caused by the streaming box (possibly a driver issue??) or 2) when this happens on a normal setup its normally caused by interference or heavy light/reflections.
I.e. playing next to a window or mirror.

dammit57

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 2
  • Last login:February 02, 2020, 07:28:51 pm
  • I want to build my own arcade controls!
Re: Aimtrak and Steamlink - Shaky cursor?
« Reply #2 on: December 12, 2019, 11:08:02 pm »
Thanks for the reply Titchgamer.

Those are some interesting leads, I'll look into them more and experiment this weekend. 

This setup has got allot of potential as a big-screen lightgun solution, if I have any luck or come across a fix I'll be sure to post it here.