Software Support > GroovyMAME

How To Adjust Individual Games Resolution?

<< < (3/6) > >>

FrizzleFried:
Aside from websites telling me... like below... I have no idea.  I DO know that my last MAME version played it fine without going in to interlaced mode... and it looked fantastic.  I also know my Pi3 also plays it fine and at 384x240 and not in interlaced mode.  I did check the manual and it doesn't indicate the resolution.  You guys are the pros when it comes to this... where do you look to source your information on resolution?

What I do know... interlaced mode sucks for this game (and at the interlaced resolution run it cuts the bottom inch off the screen too).

Here are couple websites that says it's at 384x240:

Source: http://adb.arcadeitalia.net/?mame=wcbowldx

Source: http://www.arcaderestoration.com/games/10472/World+Class+Bowling+Deluxe.aspx

The top source is a MAME engine I use to create gamelists for attract-mode.

I could keep posting but I'm up to 3 sources out of 3 that says the game runs at 384x240.

Is there something else I can do to "prove" the fact?

EDIT: And frankly,  even if I can't PROVE the fact... can someone please explain how I set it up to run 384x240 even if it's' not right because at 384 x 240 it looks great... at the interlaced mode its coming up with... it sucks.



FrizzleFried:
Also... I went out to the cab and shuffshot is using the exact same resolutions... originall 384x240 then it kicks it to 385x256 which it can't do so it uses the interlaced (doubled) version....

Calamity:
It's MAME (the emulated hardware actually) the one requesting a mode switch. Usually, this is correct. It might happen that the emulation is wrong though. I'll check in a while.

GM will do whatever is possible in order to render the game with integer scaling. Since you don't have 384x256 available, and 768x512 is exactly 384x256 x2, that's why it picks that. If you had 384x256 available, it'll pick it instead. You need 384x256 anyway, it's a basic arcade video mode, Irem, etc.

You can force 384x240 by brute force by adding these options:

resolution 384x240
intoverscan 1

Here -intoverscan is required in order to avoid GM using fractional scaling and make it crop the frame instead.

FrizzleFried:

--- Quote from: Calamity on June 18, 2019, 10:58:24 am ---It's MAME (the emulated hardware actually) the one requesting a mode switch. Usually, this is correct. It might happen that the emulation is wrong though. I'll check in a while.

GM will do whatever is possible in order to render the game with integer scaling. Since you don't have 384x256 available, and 768x512 is exactly 384x256 x2, that's why it picks that. If you had 384x256 available, it'll pick it instead. You need 384x256 anyway, it's a basic arcade video mode, Irem, etc.

You can force 384x240 by brute force by adding these options:

resolution 384x240
intoverscan 1

Here -intoverscan is required in order to avoid GM using fractional scaling and make it crop the frame instead.

--- End quote ---

Where do you add the lines above... the specific games ini file?

Thank you.

haynor666:
Some of itech32 games uses 256 lines so either use 2560x256 or 384x256 at 55 Hz. Shrinking to 240 won't look good but overscan might help unless it won't hide important part of gameplay area.

Create wcbolw.ini in ini directory and put only those lines postd by Calamity.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version