Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: Wiki isn't working yet  (Read 466 times)

0 Members and 1 Guest are viewing this topic.

saint

  • turned to the Dark Side
  • Supreme Chancellor
  • Trade Count: (+6)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6052
  • Last login:Yesterday at 07:39:26 am
  • I only work in cyberspace...
    • Build Your Own Arcade Controls
Wiki isn't working yet
« on: March 10, 2019, 11:52:21 am »
On the list
--- John St.Clair
     Build Your Own Arcade Controls FAQ
     http://www.arcadecontrols.com/
     Project Arcade 2!
     http://www.projectarcade2.com/
     saint@arcadecontrols.com

PL1

  • Global Moderator
  • Trade Count: (+1)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 7147
  • Last login:Today at 08:11:58 pm
  • Designated spam hunter
Re: Wiki isn't working yet
« Reply #1 on: March 10, 2019, 05:06:04 pm »
Wiki links on toolbar and homepage redirect to the homepage.

Links to wiki photos like this one that were working earlier today are now broken -- probably due to whatever is causing the redirect.
--------------
Wiki configuration options:
1.) Restore full read access to older wiki server and full read/login/write access to the newer wiki server. Add robots.txt on only the older wiki server.
     or
2.) Restore full read/login/write access to the newer wiki server, but leave the older wiki server configuration as-is.


Scott
« Last Edit: March 10, 2019, 06:55:43 pm by PL1 »

saint

  • turned to the Dark Side
  • Supreme Chancellor
  • Trade Count: (+6)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6052
  • Last login:Yesterday at 07:39:26 am
  • I only work in cyberspace...
    • Build Your Own Arcade Controls
Re: Wiki isn't working yet
« Reply #2 on: March 10, 2019, 09:39:41 pm »
Ah, I haven't actually created wiki.arcadecontrols.com or newwiki.arcadecontrols.com on the new server yet so it doesn't know where to send those. Will fix tomorrow.
--- John St.Clair
     Build Your Own Arcade Controls FAQ
     http://www.arcadecontrols.com/
     Project Arcade 2!
     http://www.projectarcade2.com/
     saint@arcadecontrols.com

PL1

  • Global Moderator
  • Trade Count: (+1)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 7147
  • Last login:Today at 08:11:58 pm
  • Designated spam hunter
Re: Wiki isn't working yet
« Reply #3 on: March 30, 2019, 04:45:25 am »
Another couple of weeks and I'm turning the old box off for good, just have left it up out of paranoia that I've forgotten to migrate something :)
Maybe something like the Wiki domains and files?   :P   :lol

Ah, I haven't actually created wiki.arcadecontrols.com or newwiki.arcadecontrols.com on the new server yet so it doesn't know where to send those. Will fix tomorrow.
Both domains still redirect to the homepage and image links are broken -- see sig.


Scott

Malenko

  • KNEEL BEFORE ZODlenko!
  • Trade Count: (+58)
  • Full Member
  • ***
  • Online Online
  • Posts: 13500
  • Last login:Today at 10:20:21 pm
    • forum.arcadecontrols.com/index.php/topic,142404.msg1475162.html
Re: Wiki isn't working yet
« Reply #4 on: March 30, 2019, 05:23:11 am »
/shrug
No matter one's station in life, the Dance of Death unites us all.

saint

  • turned to the Dark Side
  • Supreme Chancellor
  • Trade Count: (+6)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6052
  • Last login:Yesterday at 07:39:26 am
  • I only work in cyberspace...
    • Build Your Own Arcade Controls
Re: Wiki isn't working yet
« Reply #5 on: April 05, 2019, 01:35:51 pm »
New wiki is up and running. Probably things need to be fixed. If it's content related, users can edit so please feel free :) If it's system related, please let me know on the bug report forum.

I'll be taking a look at the old wiki next.

Current wiki is at http://wiki.arcadecontrols.com/

Thanks everyone!
--- John St.Clair
     Build Your Own Arcade Controls FAQ
     http://www.arcadecontrols.com/
     Project Arcade 2!
     http://www.projectarcade2.com/
     saint@arcadecontrols.com

PL1

  • Global Moderator
  • Trade Count: (+1)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 7147
  • Last login:Today at 08:11:58 pm
  • Designated spam hunter
Re: Wiki isn't working yet
« Reply #6 on: April 05, 2019, 04:24:03 pm »
Thanks, Saint.   :applaud:

Previous wiki username/password login works.   ;D

Text edits work -- added the new Ultimarc Rotary Upgrade to the Rotary Encoders page.

Tried to upload an updated image, but got this error message.

Quote
Action failed

Could not open lock file for "mwstore://local-backend/local-public/3/3d/RotaryEncoderLS-30Harness.jpg". Make sure your upload directory is configured correctly and your web server has permission to write to that directory. See https://www.mediawiki.org/wiki/Special:MyLanguage/Manual:$wgUploadDirectory for more information.


Scott

saint

  • turned to the Dark Side
  • Supreme Chancellor
  • Trade Count: (+6)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6052
  • Last login:Yesterday at 07:39:26 am
  • I only work in cyberspace...
    • Build Your Own Arcade Controls
Re: Wiki isn't working yet
« Reply #7 on: April 05, 2019, 05:10:52 pm »
Think I forgot to set a directory permission. Will tackle.
--- John St.Clair
     Build Your Own Arcade Controls FAQ
     http://www.arcadecontrols.com/
     Project Arcade 2!
     http://www.projectarcade2.com/
     saint@arcadecontrols.com

KDOG

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 350
  • Last login:Today at 05:32:57 pm
Re: Wiki isn't working yet
« Reply #8 on: April 16, 2019, 02:48:07 pm »
Think I forgot to set a directory permission. Will tackle.

You may want to get SirPeale to update his  FAQ locked and pinned  comment in the Main Board Thread. The links are to the old Wiki

PL1

  • Global Moderator
  • Trade Count: (+1)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 7147
  • Last login:Today at 08:11:58 pm
  • Designated spam hunter
Re: Wiki isn't working yet
« Reply #9 on: April 16, 2019, 04:12:08 pm »
Think I forgot to set a directory permission. Will tackle.
You may want to get SirPeale to update his  FAQ locked and pinned  comment in the Main Board Thread. The links are to the old Wiki
Thanks for pointing out the (currently) non-working link, but the wiki-based FAQ is only on the new wiki.

The problem is that Saint accidently restored the old and new wikis to the wrong domains.   :(
- The old wiki should have been restored to the "wiki" domain instead of the "oldwiki" domain.
- The new wiki should have been restored to the "newwiki" domain instead of the "wiki" domain.

Once Saint moves the wikis back to the original domains, all of the "newwiki" links and embedded images will work again.   ;D

For now, it looks like only embedded images from the old wiki might still work since all of those images were transferred to the new wiki.   :dunno

The old wiki didn't use ".php", so those page links will only work if you change the "wiki" part of the URL to "index.php".
    Old style page link format (returns a 404 error)
http://wiki.arcadecontrols.com/wiki/Restoration
    New style page link format
http://wiki.arcadecontrols.com/index.php/Restoration


Scott