Main > Driving & Racing Cabinets

FFB Arcade Plugin

<< < (204/208) > >>

Err, was this the post asking about flycast through Retroarch and you've edited it to nothing? I seem to remember that there is some sort of permissions issue with Flycast and the FFB plugin. First, make sure everything is set to run-as-admin. If thta fails, try turning things back to normal user one at a time.

If that fails, try launching flycast different way or adding another layer. So, if retroarch is launching a shortcut, have it launch a batfile that launches the shortcut. And run everything as admin if in doubt.

First off, this is amazing! I have San Fransisco Rush 2049 Special Edition running through mame with this and it is almost flawless!

So the feedback is good except every 2 seconds or so the power seems to cut out for a split second. It almost feels like hitting a rock in the road. You can feel it on longer turns and in the menu.
Any idea how to fix this?

Just an update on this particular problem

I re downloaded both mame and FFB plugin. Then changed the mame.ini file to say Windows instead of auto. And everything is PERFECT!

Before I comb the entire thread is there any examples of MAME crashing with this plugin?

When I open FFB GUI and select no input in the dropdown menu MAME runs fine. If I select my wheel in the dropdown then MAME crashes. Event viewer says it's a pid.dll error. Mame also works if the dinput8.dll isn't copied into the directory, so I'm getting the idea this is some kind of hardware ID issue?  Tried with MAME 262 and 254.

The plugin works fine with Teknoparrot so I know it's working with my wheel.

I'm having the same problem as @johndough247 back on page 21. MAME crashes when hooked and the test program crashes after about 8 tests. I tried older FFB plugins on older MAME versions (1.8ffb on 229mame) and the same problem occurs. I also tried renaming the dinput8.dll to the other cheeky things suggested in the "spring effect" update on github (opengl32, xinput1_3, dinput) and that didn't improve the situation.  Like johndough I have a direct drive wheel and the plugin is working great with Demul, M2, TP etc...  Really strange! I added the dinput file and my mame folder to virus exception as well, in case windows was blocking it. pid.dll error is still showing up in event viewer, if I launch via command line I get this:

Exception at EIP=00007ff8aec8266e (register_frame_ctor+0xa5817fee): ACCESS VIOLATION
While attempting to read memory at 000000281b010010
RAX=000000281b00ffd8 RBX=00000000ffffffff RCX=000000001b33f7d0 RDX=0000000000000000
RSI=000000001b33f7d0 RDI=000000001b010000 RBP=0000000011dbee40 RSP=0000000011dbedf0
 R8=0000000000000000  R9=0000000040000000 R10=0000000000000000 R11=0000000000000000
R12=0000000000000001 R13=00000000000f0034 R14=00000000000003ff R15=0000000040000000
Stack crawl:
  0000000011dbee70: 00007ff8aec8266e (DllCanUnloadNow+0x0d8e)
  0000000011dbef00: 00007ff8aec840b2 (DllCanUnloadNow+0x27d2)
  0000000011dbf080: 00007ff8aec84a9c (DllCanUnloadNow+0x31bc)
  0000000011dbf0e0: 00007ff88c9242c5 (GetdfDIJoystick+0xa105)
  0000000011dbf120: 00007ff88c9291ef (DllGetClassObject+0x3ebf)
  0000000011dbf150: 00007ff88c928a89 (DllGetClassObject+0x3759)
  0000000011dbf1a0: 00007ff88c9202e0 (GetdfDIJoystick+0x6120)
  0000000011dbf200: 000000006c834f50 (SDL_DYNAPI_entry+0xd5130)
  0000000011dbf250: 000000006c8359cb (SDL_DYNAPI_entry+0xd5bab)
  0000000011dbf2a0: 000000006c76788f (SDL_DYNAPI_entry+0x7a6f)
  0000000011dbfc90: 00007ff897bc7495 (GetdfDIJoystick+0x1405)
  0000000011dbff20: 00007ff897bc642b (GetdfDIJoystick+0x039b)
  0000000011dbff50: 00007ff8c1747614 (BaseThreadInitThunk+0x0014)
  0000000011dbffd0: 00007ff8c29a26f1 (RtlUserThreadStart+0x0021)

last edit;
Similar to MAME, Flycast crashes as well with the plugin installed and wheel selected in the GUI.

Through googling I came across some wild man over on steam playing Dirt with FFB issues and a dll error. He moved immpid.dll (not exactly my pid.dll issue, but oh well) from syswow64 to system32. This seemed to help his situation. Moving the pid.dll from the 64 bit to the 32 bit location did not help my situation. I did notice that the pid.dll error showing up in event viewer is from the system32 folder though, NOT the syswow64 folder. I have 64bit mame installed with the respective 64bit ffb.

Everyhing's working with:
Demul, Model 2, all Tekno games

It's not working with:
Supermodel3 (that's ok, the native FFB works fine), Flycast, and MAME

Other attempted shenanigans included installing the 32bit version of the plugin in MAME, then swapping just the mame64.dll into the folder, then combinations of these things with different pid.dll copies in different folders. At this point I have to throw my hands up. It's odd that it works so well with some things and not at all with others, hoping Boomslang comes to the rescue so I can finally play Virtua Racing properly!


[0] Message Index

[#] Next page

[*] Previous page

Go to full version