Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Beginner Help Needed  (Read 504 times)

0 Members and 1 Guest are viewing this topic.

MK3U2012

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 20
  • Check out my reviews on KLOV
Beginner Help Needed
« on: April 15, 2018, 02:12:31 pm »
running mame version .161 paired with rocket launcher and using hyperspin version 1.4 as a front end.

I am capable of successfully loading and playing games through hyperspin. Only trouble is only 341 of the over 8000 games are available to play with the rest being in red. And of the 341 there are many that either start to load and kick back to menu of load into an unplayable game.

Im wondering if either my mame version, romset or both are not complete, working or compatible?

Any help is greatly appreciated and after thoroughly reading the rules im hoping i have not broke any with the above post.

Thanks
Blake

PL1

  • Global Moderator
  • Trade Count: (+1)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6749
  • 2013 UCA Awardee
Re: Beginner Help Needed
« Reply #1 on: April 15, 2018, 04:20:46 pm »
Based on "8000 games" and this chart, it looks like your ROMset is older than v0.161 (Maybe v0.141?) and is probably missing many BIOS and driver files.

It's usually easier to find a known version ROMset first, then download the matching version of MAME.

If you want to use a "no-nag" version of MAME, get things working with the regular version first or you won't see the useful info telling you why MAME is not working right.


Scott

MK3U2012

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 20
  • Check out my reviews on KLOV
Re: Beginner Help Needed
« Reply #2 on: April 15, 2018, 05:18:57 pm »
sorry for the lack of knowledge when it comes to terminology but what is no-nag and also what would be considered a normal version of mame?
thanks
blake

MK3U2012

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 20
  • Check out my reviews on KLOV
Re: Beginner Help Needed
« Reply #3 on: April 15, 2018, 05:24:11 pm »
i know the romset was listed as .161 but i guess that could be false.  is there a way to identify for sure?  I would be happy to download a known good romset and match the mame version download but so far im 0-2.
thanks
blake

PL1

  • Global Moderator
  • Trade Count: (+1)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6749
  • 2013 UCA Awardee
Re: Beginner Help Needed
« Reply #4 on: April 15, 2018, 07:00:45 pm »
what is no-nag and also what would be considered a normal version of mame?
"Nag" screens are the info that MAME displays when you launch the game.

- On most games, MAME just asks you to move the joystick left then right to continue.

- On some games, there may be warnings that the emulation is not working right yet.

MAME Devs hate the "no-nag" versions that bypass these info screens because noobs submit bogus/repeat bugfixes like "Simpsons Bowling sound is messed up." which they would have known if they had seen the warning screens.

If you download MAME from the MAMEDev.org site, it will be the baseline "vanilla" version -- newest release here or older releases here.

i know the romset was listed as .161 but i guess that could be false.  is there a way to identify for sure?
It probably is 0.161, but it might be incomplete. (deleted non-working games or clones)   :dunno

Assuming that it is a complete set, here are two quick-and-dirty tests that should confirm.

The "What's New" for v0.161 mentions that "Stadium Cross (World, alt)" was added as a new clone.
- If the ROMset contains the file "scrossa.zip", it is v0.161 or newer.

The "What's New" for v0.162 mentions that "Contra (US / Asia, set 3)" was added as a new clone.
- If the ROMset contains the file "contrae.zip", it is v0.162 or newer.


Scott

MK3U2012

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 20
  • Check out my reviews on KLOV
Re: Beginner Help Needed
« Reply #5 on: April 15, 2018, 07:14:27 pm »
so there is no "scrossa.zip"
there is no "contrae.zip" but there is a "contra1.zip"

each of the versions of mame ive download have been from mamedev

For the hell of it i just downloaded .141 version of mame and that seems very odd as it does not even have the mame emblam

thanks
blake

PL1

  • Global Moderator
  • Trade Count: (+1)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 6749
  • 2013 UCA Awardee
Re: Beginner Help Needed
« Reply #6 on: April 15, 2018, 08:29:41 pm »
There's probably some configuration problem with MAME, HyperSpin, or Rocket Launcher.

Have you tried launching MAME without using HS/RL?


Scott

MK3U2012

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 20
  • Check out my reviews on KLOV
Re: Beginner Help Needed
« Reply #7 on: April 15, 2018, 09:41:30 pm »
no i have not given that a shot let me see if theres any change.
thanks
blake

MK3U2012

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 20
  • Check out my reviews on KLOV
Re: Beginner Help Needed
« Reply #8 on: April 15, 2018, 10:27:37 pm »
well i must be doing something wrong because ive moved my mame setup folder from my c drive to my external hard drive which is where my full romset is located.  then i moved the folder with all the zipped roms into the rom folder of the mame setup and it does not see them.  there is no interface with this version of mame, well i should say a very plain interface that im not very familiar with the commands so i have not been able to get it to search for the rom set.  ill try more tomorrow.
thanks
blake

MK3U2012

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 20
  • Check out my reviews on KLOV
Re: Beginner Help Needed
« Reply #9 on: April 16, 2018, 02:48:41 pm »

so the .196 romset downloaded successfully and im now showing almost 8 k of games in the green. i still have to reconfigure everything to be able to play them and im hoping to do that tonight. ill keep you posted.
thanks again
blake 

MK3U2012

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 20
  • Check out my reviews on KLOV
Re: Beginner Help Needed
« Reply #10 on: April 16, 2018, 05:08:05 pm »
so as i was configuring i noticed that mame does not launch.  it has a window that blinks quickly and thats it.  no error message, no menu, and nothing loaded.  Im wondering if i need to have a higher .netframework as my vista currently only has 3.5 i believe and sometimes after booting gives me an error message but then moves forward without issues.

Everything is smooth other than that.

thanks
blake

MK3U2012

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 20
  • Check out my reviews on KLOV
Re: Beginner Help Needed
« Reply #11 on: April 16, 2018, 09:41:37 pm »
so i borrowed another more modern laptop and hooked up the external hard drive and mame popped right up. so at least we verified its a good download.
thanks
blake

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31