Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: So My MAME PC Went Bye Bye..........a Horor Story  (Read 723 times)

0 Members and 1 Guest are viewing this topic.

mike boss

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 2526
So My MAME PC Went Bye Bye..........a Horor Story
« on: February 24, 2018, 08:17:03 pm »
Here's the run down.
My man cave consists of  :

23" all in 1 Gateway PC currently used as a dedicated Touch Jams jukebox
FAS Foosball table
Final Fight cabinet (outside in the garage)
Bad Dudes cabinet (outside in the garage)
Nintendo Punch-Out custom Raspberry Pi bartop (project....STILL in the works)
Nintendo Donkey Kong Jr cabinet running MAME & MaLa with a scanline generator (19" LCD)
Nintendo Donkey Kong cabinet running a 60-in-1 board with a scanline generator (19" LCD)
Nintendo Popeye Cabinet with a Pandora's Box 3 board (24" LCD)
Nintendo Mario Bros MAME/Mala cabinet with 2 Aimtrak light guns and NES, Sega Master System, Sega Genesis, and Turbo GRFX emulators. (21" CRT)

My Mario Bros is no doubt my most used and favorite cabinet in my lineup. I spent a lot of time working on the set up. Perfecting my gameslists and creating some custom artwork to serve as a user manual for guests when they come over. I've got everything set up just the way I like it. I was really really happy with the set up. All my Mortal Kombat games added conveniently into one list, all my Street Fighter games added conveniently into a list of their own. Games were further broken down into a separate list for fighters, TMNT games, and even Wrestling Games. I used to have a few more emulators installed, but I was unable to configure them and had since removed them. Everything that remained on the cabinet was set up and working well.

So the other day I take my little man (who's 2) downstairs to show him Spider-Man on the cabinet. He's obsessed with "man man" as he calls him. So I fire up the cabinet and the game freezes.............I leave it for a few seconds, but it just hangs and doesn't resume playing. So I power down the cabinet, and power it back up. Something told me the issue was bad, but I didn't pay attention. So the PC comes on, I can see the BIOS and booting process begin and it hangs....I pay ZERO attention to way it says. I power down and power on again now I get NOTHING!

My PC skills are limited so I probably tried a few more times to turn it on/off with the same result. The PC is f**t !
I take everything out, the RAM, video card, sound card, and put it all back in making sure the connection is good. I notice the motherboard is getting power as the LED on the board is lit up and the fans come on. But I notice the LED on the mouse does not come on.
I think perhaps it is a problem with the 5 volt ? So the following day I go out and replace the power supply. The issue persists. I see nothing on the monitor. I test the video card on a different PC. I can confirm the video card is not the issue.

I dock the hard drive in my HDD dock, the drive is fine. I'm able to pull all the date off the drive. So all my ROM files, artwork, etc are all safe. I go into my storage and pull out a PC I had bought YEARS ago off a buddy. I never did find a use for it, so why not dig it out and put this into my Mario Bros cabinet.

So I have this new (old) Asus motherboard, a new (old) hard drive, and all my files are safe. I try to format the drive from a USB flash drive I have containing a Windows 7 image. I can't get it to work. So my buddy from the work, the tech guy so to speak takes the HDD and plugs it into my net PC to format the drive off the usb. We do that, it works. We take the drive back to the new MAME pc, plug it in............boots, crashes, blue screen, nadda ! I'm told you can't format the drive in one PC then add to another. I go out and buy a used DVD drive as the DVD drive I had did not work. I install a fresh copy of Windows 7 onto the drive, and I must have selected the repair option. All my MAME & MaLa files remained on the drive. This is awesome ! Don't need to do the work twice.

But despite copying everything over it wasn't just plug in play. I had to try and remember what I named everything, recreate the path names, etc. What I thought would be so easy and such little work was anything but. And with 2 lil kids I don't get much time to get on the PC.

So I'm at work and complaining to my buddy, the "tech guy" the "I.T" guy........ and I'm telling him, "dude you can't format the HDD on one PC, toss it in another, it does't work!" He insists he's done it before.........many a time ! And it works.
So I go home, I take the HDD from my Mario Bros set up, I plug it into the replacement PC.............f'n thing works! Boots up, no problems. I don't know if it worked cause they were both Asus boards....but it worked ! I still wasted a few hours, but the good thing is I won't need to configure everything again, and I've still managed to copy all the files over to another PC.

So I can hopefully toss this PC back into Mario Bros this weekend and finish installing the Aim Trak guns. And now I've got a HDD that is well underway for a possible all light gun MAME & MaLa set up that I was thinking of doing.

What a pain in the butt !

JDFan

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 2983
  • I want to build my own arcade controls!
Re: So My MAME PC Went Bye Bye..........a Horor Story
« Reply #1 on: February 24, 2018, 08:44:18 pm »
Over the years Windows has gotten much better at being able to repair itself when you move a HDD with the OS on it into a new PC - When it boots it will notice the hardware is different and redo the drivers etc. so it will usually work (though the first boot might take a bit extra time) esp. if the MOBOs are similar - You might wind up having to reactivate the install as it will probably deactivate itself due to the hardware changes - so be sure to check the activation status ( easier to do now and have the 30 days to correct if needed than to wait and get the activation warning when it's about to stop working. )


mongoosetoo

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 11
  • If you ain't first, you're last!
Re: So My MAME PC Went Bye Bye..........a Horor Story
« Reply #2 on: March 24, 2018, 10:25:02 am »
  I am a IT guy day, and a arcade hobbyist by night - and have built a bunch of them over the years for people.  I almost always start with someone's old computer that's been unplugged in a closet and build it from there.  To simplify, the builds, I add a second hard drive to whatever PC I use with ONLY arcade stuff on it.

  Hard drive 1 (usually C: drive) contains everything specific to the computer - Operating system, drivers, etc.  Hard drive 2 contains everything MAME or emulator related.  Depending on what kind of encoder you are using for joystick commands (IPAC, keyboard encoder, Tankstick, etc.) you may have to upload those drivers to C drive, but that's about it.

  I keep a couple backups laying around  - one on the shelf, and one on my home network.  That way I don't have to panic when a PC dies.  Also, in building arcades for friends, I can always borrow their copy if things go south.

  Likely what happened in your case, was one computer was 32 bit and the other was 64 bit.  Different architectures usually aren't very compatible.  Using my approach above, avoids all the hassle.  Besides - in a dedicated machine, it's best to keep your Operating System separate from the main application anyway.  Your Operating system drive can be installed on a relatively small hard drive too to save $$.  I use whatever I have laying around the garage - usually 10 or 20 GB for the OS drive.   

   And one more piece of advice... once the machine is set up and working fine, unplug it from the network and only use it for your MAME.  My own personal machine hasn't had a single issue in 6 or 7 years, and hasn't been connected to the network, web, or updated in that time.  Junk computers are easy enough to find  - especially because most emulator/ROMs don't require a beast of a machine to get them to work. 

Hope this helps.
 

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31