Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Problem launching Dead Heat arcade with an Intel HD 530  (Read 360 times)

0 Members and 1 Guest are viewing this topic.

mickael28

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 93
  • I want to build my own arcade controls!
Problem launching Dead Heat arcade with an Intel HD 530
« on: October 04, 2017, 04:56:38 pm »
I found the following instructions from @Harry99710 for being able to launch the Dead Heat game:

Quote
Go here for 32bit ubuntu http://releases.ubuntu.com/16.04/and chose the 32bit desktop image (see image)
For the library go here https://packages.deb...libsdl-image1.2and choose i386 then select a download mirror that's closest to you. open the deb file in ubuntu and click install, put in your password and it should install
for the sound fix press ctrl + alt + t and type in
sudo nano /etc/asound.cfg
 and paste in the stuff below
#5.1 to stereo downmix - manual with no plugin
pcm.!sysdefault {
slave.pcm front
slave.channels 2
type route # input output scaling
ttable.0.0 1 # fl left 100
ttable.1.1 1 # fr right 100
ttable.2.0 1 # rl left 100
ttable.3.1 1 # rr right 100
ttable.4.0 0.5 # ctr left 50
ttable.4.1 0.5 # ctr right 50
ttable.5.0 0.5 # lfe left 50
ttable.5.1 0.5 # lfe right 50
}
then press ctrl + x and then press y followed by enter then close the terminal window
 
install drivers for your Nvidia card by clicking the system settings icon then go to software & updates section. in the software and updates window click on additional drivers and select nvidia binary driver (normally at the top) and press apply changes.
 
Once they have installed reboot the computer
 
now go into the folder where you extracted dead heat's files and right click in that folder and select open in terminal
paste in
LD_PRELOAD=./dh_emu.so ./a.elf
and the game should launch


I've got a Windows PC with an integrated Intel HD 530 graphics card though, and I read some comments where they mentioned that it was required to run in Linux and if one didn't have Nvidia cards, it could cause graphic problems.

As I don't currently have an Nvidia, I was not expecting it to run properly, but at least I was expecting it to launch and see how it looked.

I followed the instructions above in a full Ubuntu version that I had on a new USB drive. Just in case, I installed the nVidia drivers as well (even though I've got a different card) and I created the config that he mentions regarding the sound in two files (/etc/asound.cfg and /etc/asound.conf) as I was not sure which one was correct after reading several threads.

Problem is that when I try to launch the game I get:

Code: [Select]
sudo LD_PRELOAD=./dh_emu.so ./a.elf DH_CAMERAFIX=1 DH_SOUND_F

Code: [Select]
* nsAdrv: cannot open audio device surround51 (No such file or directory)
which doesn't seem to be related to the graphic card, I guess, but that's it, the command terminates there.

Can you think of anything that I could try or double check to see if at least I manage to launch the game?

shaolindrunkard

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 253
Re: Problem launching Dead Heat arcade with an Intel HD 530
« Reply #1 on: October 05, 2017, 02:48:48 pm »
Last I heard it only runs on Linux, but I could be wrong about that.

Not to be a downer but Dead Heat is considered one of the worst arcade racers of all time, so I wouldn't spend too much time trying to get it  running.

I know a lot of these Arcade dumps are coming out and its tempting to try and get them all going but some of them are of poor quality, just no fun and really not worth wasting the time trying to get them working...

Good luck

mickael28

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 93
  • I want to build my own arcade controls!
Re: Problem launching Dead Heat arcade with an Intel HD 530
« Reply #2 on: October 05, 2017, 04:50:13 pm »
Yes, I read it runs in Linux only as well. I was trying on a full Ubuntu version that I've got running from an external USB at the moment.

I've kept it configured with the issue I've got at the moment, so if anyone can think of anything I could try in the future, I could give this a go, as I don't know what the error is at present.

I've never played that game but the youtube videos look pretty good. What I've noticed though, that sometimes the games that get really high ratings are not my style, and the games that people don't quite like, I really enjoy. It's usually more a matter of trying for 10 minutes and seeing how much one likes them...

But in this case, yeah, quite tricky to get it running if one doesn't have much knowledge about linux it seems.

MrThunderwing

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 455
  • As I pass, do I give you the ass or the crotch?
Re: Problem launching Dead Heat arcade with an Intel HD 530
« Reply #3 on: October 05, 2017, 05:53:07 pm »
Last I heard it only runs on Linux, but I could be wrong about that.

Not to be a downer but Dead Heat is considered one of the worst arcade racers of all time, so I wouldn't spend too much time trying to get it  running.

I know a lot of these Arcade dumps are coming out and its tempting to try and get them all going but some of them are of poor quality, just no fun and really not worth wasting the time trying to get them working...

Good luck

Good advice. I've spent ages in the past trying to get certain cracked arcade games to work, only to ever play them a handful of times. Sometimes it's just not worth the hassle.

shaolindrunkard

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 253
Re: Problem launching Dead Heat arcade with an Intel HD 530
« Reply #4 on: October 06, 2017, 12:20:50 pm »
I've done it far too many times to count. Trying to use my head from now on regarding these things...  :)

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31