Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Model 2 Emulator crashing when setting up Logitech Wingman Force GP  (Read 355 times)

0 Members and 1 Guest are viewing this topic.

tylerwerrin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 64
  • I want to build my own arcade controls!
Hi guys,

As the subject line says, whenever i try to map my Logitech Wingman Force GP wheel's Axis', the Model 2 emulator crashes. I've tried checking the boxes next to the Steering, Brake and Accelerator options under "Controls", and saving that selection, but if I double click on the selection itself, the emulator will immediately crash.

The steering seems to work fine for all of the driving games, however the brake and accelerator are the problem. The steering wheel works fine in MAME and other racing games.

Has anyone else had this problem or knows of a workaround?

BadMouth

  • Trade Count: (+6)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 8078
  • My arcade cabinet has a cup holder.
Re: Model 2 Emulator crashing when setting up Logitech Wingman Force GP
« Reply #1 on: September 12, 2017, 10:41:42 am »
See the stickied model 2 guide thread as well as the stickied driving cab info thread in the driving cab subforum.

Do you have any other controllers plugged in?
IIRC, you can only have one plugged in at a time when mapping controls.

The pedal problems are probably caused by having the pedals set to combined instead of separate and/or not having one or both axis inverted.
These games all need to be set up individually.

tylerwerrin

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 64
  • I want to build my own arcade controls!
Re: Model 2 Emulator crashing when setting up Logitech Wingman Force GP
« Reply #2 on: September 22, 2017, 09:44:46 pm »
the only other controller i have plugged in is my trackball and GPwiz 40 (for joysticks). I have a mouse and keyboard hooked up, could that be causing the issue?

BadMouth

  • Trade Count: (+6)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 8078
  • My arcade cabinet has a cup holder.
Re: Model 2 Emulator crashing when setting up Logitech Wingman Force GP
« Reply #3 on: September 22, 2017, 10:45:48 pm »
The GP Wiz (anything that shows up as a game controller) is the issue.  Unplug it while mapping the controls that are on the wheel.  If you want to also map some buttons from the GP wiz, it has to be done while the wheel is unplugged.  (Plug in only wheel, map controls on wheel, exit emulator, unplug wheel, plug in gpwiz, launch emulator, map gpwiz, exit emulator, plug both back in, launch emulator and they should both work in game)

At least that's how it worked for me.  That's a pretty old wheel there IIRC.  Some of those early wheels don't play nice because there was no standard protocols for force feedback yet.
« Last Edit: September 22, 2017, 10:48:59 pm by BadMouth »

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31