Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Known issues with mame ini file handling in 0.188 and up  (Read 801 times)

0 Members and 1 Guest are viewing this topic.

krick

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1826
  • Gotta have blue hair.
    • Tank + Paladin = Tankadin
Known issues with mame ini file handling in 0.188 and up
« on: September 02, 2017, 01:54:12 am »
Upgraded from 0.185 to 0.188. Mame ignores vertical.ini if I had previously opened horizontal game
https://www.reddit.com/r/MAME/comments/6w1nd9/upgraded_from_0185_to_0188_mame_ignores/

Mame Dev response...
Quote
There are a number of issues with the options system in 0.188 - we know about this, and it will be addressed. Unfortunately addressing it properly will be a lot of work, so it won't be ready for 0.189, and possibly not for 0.190. In the mean time, please accept our apologies and try to bear with us. If this completely breaks your setup, all I can really recommend is staying with 0.187 until this is all resolved.


Doozer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 300
  • Z80 ERROR
Re: Known issues with mame ini file handling in 0.188 and up
« Reply #1 on: September 02, 2017, 04:55:51 am »

Hi krick,

MAME devs did some modifications to the ini/option system in v0.189. You can give it a try to see if it solves your issues. Nevertheless, the 0.0189 does not address all problems.

Cheers,


Robbbert

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 61
Re: Known issues with mame ini file handling in 0.188 and up
« Reply #2 on: September 02, 2017, 06:23:48 am »
0.189 added some new problems, mostly within the built-in UI. Most of these problems will cause MAME to crash.

Either stay with something from a few months back, or wait for it to be properly fixed.

krick

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1826
  • Gotta have blue hair.
    • Tank + Paladin = Tankadin
Re: Known issues with mame ini file handling in 0.188 and up
« Reply #3 on: September 02, 2017, 10:38:29 am »

You can give it a try to see if it solves your issues.


They're not my issues.  I was just relaying the experience of a user on Reddit and the comment from MAME dev.

I didn't know if GroovyMAME users (or Calamity) were aware that there were problems with the ini handling in version 0.188 and up.

Since GroovyMAME users often use vertical.ini, vector.ini, and other ini files for specific edge case games that need special attention, they might not want to be in a hurry to upgrade to a newer GroovyMAME just yet.

I think I'm going to stick with GroovyMAME 0.186 for the time being.

haynor666

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1071
  • retro maniac
Re: Known issues with mame ini file handling in 0.188 and up
« Reply #4 on: September 22, 2017, 04:59:36 pm »
Try latest GIT - https://mega.nz/#!1lUlBb6Z!Xpw-MOJ_Aj_Ef60JBWEO-1hjs3LwGGebrIKHZgRRhek

This is groovymame patch 189 applied to latest source from today.

haynor666

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1071
  • retro maniac
Re: Known issues with mame ini file handling in 0.188 and up
« Reply #5 on: November 16, 2017, 07:29:54 am »
Any improvement in 191 ?

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31