Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Setting up Control Panel issues (Trackball/Spinner)  (Read 541 times)

0 Members and 1 Guest are viewing this topic.

SpyhunterUK

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • I want to build my own arcade controls!
Setting up Control Panel issues (Trackball/Spinner)
« on: August 14, 2017, 04:03:58 am »
I am setting up my control panel and have some NOOB questions.  I have searched the internet but thought it be quicker and better to discuss with others who may have had the same issues.  Help!

1.) How do I setup the spinners?  (1x iPac Ultimate, 1x USB) = are they suppose to appear as a gaming controlle in windows and when pressing in MAME control setup?
2.) How can I setup Amitrak Light Gun?  It ran the setup program one but no longer runs so I cannot calibrte? (I have reinstalled)
3.) The trackball is odd which points to the cabling into the iPac Ultimate.  Up/Down is fine, Left and Right is odd.
What are the connections into the Ipac from the Trackball suppose to be (cable colours into iPac?)
G, X1, X2, 5v
G, Y1, Y2, 5v
4.) Also how can I add Mouse Buttons to the trackball? - wire the connections on the Trackball straight to the iPac for Mouse Buttons?
5.) iPac Ultimate Firmware is 1.3 - is it worth upgrading, if available?
6.) All my buttons light up then go off.  I am running LEDBlinky but what do I need to do now to get them staying on for each game in MAME and otehr emulators?
7.) Lastly I bought the speaker and amip kit from Arcade World but find it rather hissy and not very clear - are they suppose to be like that or do you think they have a problem and should be sent back?

Thanks.
« Last Edit: August 14, 2017, 04:06:23 am by SpyhunterUK »

Titchgamer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1969
  • I have a gaming addiction.....
Re: Setting up Control Panel issues (Trackball/Spinner)
« Reply #1 on: August 14, 2017, 08:07:48 am »
The spinners should show up as a mouse (same as trackball)

Whats your problem with the aim trak specifically?

You can set LED's to light for individual games through LED blinky. It will need to be set up and configured as per the instructions.

As for the speakers and amp what do you have the volume set at? They dont need to be to high.
Also keep all audio leads away from power cables otherwise they will introduce interference.

SpyhunterUK

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • I want to build my own arcade controls!
Re: Setting up Control Panel issues (Trackball/Spinner)
« Reply #2 on: August 16, 2017, 04:48:28 am »
Here's the latest update:

Light Gun
Amitrack now runs correctly.
Although should the light test show the gun light in opposite mode when viewed (moving gun up moves the light sensor down).

Spinner
These are not shown as inputs as all, I will check the iPac connections.  Although the 2nd Spinner is connected via USB.
Not showing under Game Controllers at all.
Just to confirm, where should the cables be connected.  I have conected into the Spinner section of the Ipac but when running the software the Spinner and Trackball are faded out (disabled), even after it is enabled and set, a re-run of the iPac (after saving) still shows them disabled.
Although Player 3, RT, LF, UP and DN are lite up???  Nothing is plugged into them.

I am running iPac 1.3 Firmware- is it worth updating?

USB Spinner: This connecting into the adapter board (USB) via the Brown, Green, White, Yellow cables - can anyone confirm whether this is correct and where it should go.

Could I also confirm the wiring for the TRACKBALL as I seem to have the X,Y mixed up and can't work out how to fix.
Currently these are the conenctions:

iPac   G   X1   X2   5v
   G   Y1   Y2   5v

And these are how I have connected to the Trackball as above:

TBall   Red   Yellow   Green   Black
   Red   Blue   Purple   -

What am I doing wrong?


LEDBlinky
I have managed to setup the LEDs to controls/buttons in the setup config.  I have linked to GameEx and MAME but when I run a game nothing happens? 

I have followed all the instructions online but seem to have a dead end to get these working so any suggestions or help would be great!

I have linked a new Amp to the speakers and they work OK.  I have decided to scrap the Amp I have (Arcade World kit) and purchase a 2.1 speaker system for the arcade.

AndyWarne

  • Trade Count: (+18)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1838
    • Ultimarc
Re: Setting up Control Panel issues (Trackball/Spinner)
« Reply #3 on: August 16, 2017, 12:43:59 pm »
The trackball and spinner will not show up in Game Controllers as they are mouse devices. But they should move the mouse pointer on the desktop.

I am not clear on what board you have but it sounds like it must be an I-PAC Ultimate I/O. The trackball and spinner inputs on this are by default enabled and should work immediately so it suggests incorrect connection.

The issue might be better resolved by email: andy@ultimarc.com

SpyhunterUK

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 21
  • I want to build my own arcade controls!
Re: Setting up Control Panel issues (Trackball/Spinner)
« Reply #4 on: September 06, 2017, 05:50:12 am »
All sorted with Andy, many thanks.

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31