Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Having a problem with the Ipac4 and the Optipac talking to the pi  (Read 433 times)

0 Members and 1 Guest are viewing this topic.

Vestal

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 19
  • I want to build my own arcade controls!
Hello

I have a 4 player arcade machine that I built and everything is programmed and fired up.  I got green lights on both packs.  Plugged them into my main machine and looked at them both with winpac. Everything is mapped correctly on the Ipac4.  I can not get it to talk to the raspberry pi3.  I am running retropi. I plugged in a regular keyboard and everything is working awesome.  I can not get my buttons to communicate to through the ipac4 so I can map the buttons and play.  The only thing that works is the Player one joystick.  If I hold that up it will recognize my controls as a keyboard and it maps the up stroke at "key`".  From what I read online - this is correct.  I also have a button that sticks once in a while and that is the player one coin button which shows up as a #5 stroke.  And that to is correct.  I know what you are thinking... but all my buttons are wired correctly as they have four pins 2 for the switch and two for the LED.  All the LED's are on and the grounds/commons are on the same side leaving the only one left at the switched wire and that is wired to the Ipac4. 

I am at a loss. :angry:  Everything I read is that the Ipac4 should just take off as a regular usb device.  What am I missing.  It screams driver issue, but my windows pc recognized it.  Is there something special I have to do with the PI3??? :badmood:

Anyone out there that can help with this?- I am so close to having an awesome arcade machine. :banghead:

I have the same post on the main forum if you want to see pics. - please help!!!

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31