Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Mala Frontend problem  (Read 226 times)

0 Members and 1 Guest are viewing this topic.

litros5

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 1
  • I want to build my own arcade controls!
Mala Frontend problem
« on: March 19, 2017, 08:41:17 pm »
Hi everyone! I have a little problem with my emulator mala. It has been working properly since I need to assign the buttons. I do it other times but this time I leave the IU select button without any selection. So now, when I'm going to enter in one of the parts of the meny (Input general, Input this game...etc), I can't do it. I can move through them, but not get in. Usually I access with enter, but now it's impossible.

I try it a lot of things as delete the program and install it from zero. But it has not helped. However, in other pc it is possible onli copying the same folders.

I don't understand it. So please, help me!

I'm sorry for my english!

big10p

  • Trade Count: (0)
  • Full Member
  • ***
  • Online Online
  • Posts: 536
  • Mmmm, arcade classics!
Re: Mala Frontend problem
« Reply #1 on: March 20, 2017, 09:56:15 am »
Sounds like you're talking about MAME not MaLa (which is a frontend, not an emulator).

Anyway, plug in a mouse and double click on 'UI select'. This will let you define a key for it. You may also need to set ui_mouse 1 in mame.ini for this to work properly.
« Last Edit: March 20, 2017, 10:02:25 am by big10p »

Cynicaster

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 375
Re: Mala Frontend problem
« Reply #2 on: March 20, 2017, 10:13:55 am »
Functions like “input this game” and “input general” are MAME configurations, not MaLa. 

Sounds like you may have accidentally goofed up your configuration file.  Go into your mame\cfg folder and find the file DEFAULT.CFG.  That file contains the key mappings for the MAME user interface, including the “select” feature you’re looking for.  You can manually edit it and re-save, or if you’re not comfortable editing configuration files, just delete the file and launch MAME.  Since MAME will not see a default.cfg, it will create a new one with default settings, and you can go in and reconfigure it to your liking. 

At least, this is how I’d do it with the MAME versions I use; not sure if the config file architecture has changed in later versions. 

EDIT--looks like somebody already answered your question. 


  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31