Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: RETROARCH - Problems mapping anything to it  (Read 409 times)

0 Members and 1 Guest are viewing this topic.

usaf-lt-g

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 44
  • I want to build my own arcade controls!
RETROARCH - Problems mapping anything to it
« on: March 01, 2017, 07:23:53 pm »
I actually have a few problems but Retroarch seems to be nasty thorn in my side.

I use HyperSpin/RocketLauncher/LEDBlinky flawlessly now on MAME. However I've seen loads of posts of people raving about Retroarch and how great it is... Yet... I for the life of me can not get it to play nicely at all for any emulator let alone the UI itself.

My CP is a 4 player setup with some extra admin buttons all hooked up through an Ultimarc Ultimate I/O board. I can get Retroarch to launch correctly and I've tried to setup Sega Genesis, Nintendo, SNES, TG16, and Atari but for the life of me, I can NOT seem to get the joysticks to map correctly or the buttons.

I think the intuitiveness of the interface isn't meant for Arcade Style CPs... But maybe that's just me. There's nothing super special about my CP other than it looks nice. Happ Comp Joysticks, Ultimarc uled buttons, a u-track, and a u-spinner...

Has anyone else been successful in this? Should I just say f it, and download standalone emulators for each system instead? I was trying to simplify the process and apparently it's not helping.

Also another problem... daphne.... I'm running my screen in a vertical position. game launches, I can hear sound.... But there's no picture for any game being launched.


Sent from my iPhone using Tapatalk

wemr97dl

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 137
  • KEEP GOING!
Re: RETROARCH - Problems mapping anything to it
« Reply #1 on: March 06, 2017, 06:35:53 am »
I'm messing with it now and not having any luck, but still trying for now. I have an ipac 4 and can't get any controls mapped for it either.


Sent from my iPhone using Tapatalk

wemr97dl

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 137
  • KEEP GOING!
Re: RETROARCH - Problems mapping anything to it
« Reply #2 on: March 06, 2017, 09:22:42 pm »
I just set up sega genesis and finally did get my ipac 4 mapped correctly, I have not done any other system.
What i found helpful was this page
https://github.com/RetroPie/RetroPie-setup/wiki/RetroArch-Configuration
I printed out a pic of the Megadrive/Genesis (6 Button) controller and used as a guide when mapping.
under inputs, I have it set to retropad, I'm not at my computer right now and connot remember the setting but a few settings down is another setting that has an option of Ipac4 and set that to it, with the picture and my CP same layout a yours i was able to map all my controls one at a time, its just easier than hitting all and rushing threw them. The only problem I had is the player one joystick kept showing up numpad 8,6,4,and 2. I had to open up the config file in notepad++ and change them to up down left and right, its way down the list you'll find it if you have to. After thinking about it I may have my numbers lock on my keyboard  which may be causing it?
Like I said I am staring a new Rocket launcher set up and trying to get everything updated so this is the only one I have done and everything seems to be working great for now.
Also using the images you can get the idea of how each different systems controllers corrisponds to the Retroarch Pad setup
hoop it helps

wemr97dl

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 137
  • KEEP GOING!
Re: RETROARCH - Problems mapping anything to it
« Reply #3 on: March 06, 2017, 09:48:59 pm »
I just set up sega genesis and finally did get my ipac 4 mapped correctly, I have not done any other system.
What i found helpful was this page
https://github.com/RetroPie/RetroPie-setup/wiki/RetroArch-Configuration
I printed out a pic of the Megadrive/Genesis (6 Button) controller and used as a guide when mapping.
under inputs, I have it set to retropad, I'm not at my computer right now and connot remember the setting but a few settings down is another setting that has an option of Ipac4 and set that to it, with the picture and my CP same layout a yours i was able to map all my controls one at a time, its just easier than hitting all and rushing threw them. The only problem I had is the player one joystick kept showing up numpad 8,6,4,and 2. I had to open up the config file in notepad++ and change them to up down left and right, its way down the list you'll find it if you have to. After thinking about it I may have my numbers lock on my keyboard  which may be causing it?
Like I said I am staring a new Rocket launcher set up and trying to get everything updated so this is the only one I have done and everything seems to be working great for now.
Also using the images you can get the idea of how each different systems controllers corrisponds to the Retroarch Pad setup
hoop it helps
Hope

One more thing make sure you save each player as you do it. I kept getting an error when saving player 4 but when I checked the coding file it was all there haven't tried the player 4 controls yet but if there is a problem I'll post it here


Sent from my iPhone using Tapatalk

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31