Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: rockola 940 with a slow turntable  (Read 369 times)

0 Members and 1 Guest are viewing this topic.

George

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • I want to build my own arcade controls!
rockola 940 with a slow turntable
« on: February 14, 2017, 08:06:44 am »
I am new to this forum so please bear with me. One of my three juke boxes is a Rockola 940 that has always worked well, but it hasn't been played in a while. After start up, I noticed that everything worked but the turntable was spinning 34 rpms like for playing an LP. The voltage to the turntable motor is 120 volts and I don't see any binding of the drive wheel or platter. I did notice that the power distribution box has four monitor lamps. The second lamp, labeled -28v, has a very faint glow, unlike the other three which are bright. Any help would be greatly appreciated and thanks for the opportunity to post my problem.

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31