Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: GroovyMame, throttle has no effect.  (Read 422 times)

0 Members and 1 Guest are viewing this topic.

noldor

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 3
  • I want to build my own arcade controls!
GroovyMame, throttle has no effect.
« on: February 14, 2017, 01:36:15 am »
Hello all.

I built my arcade cabinet in 2009 and it has been running fine since then. It ran on a 1ghz athlon in dos with an old version of mame.
Seeing as parts has become harder to come by and the IDE hdd died a couple of months ago i decided to upgrade.
I upgraded to the following setup.

MB : Sapphire Pure White Fusion Mini E350
CPU : AMD E350
RAM : 4GB DDR3-1066
GPU : Integrated (Radeon HD 6310)
Monitor : Syncmaster 245B Plus
HDD : Samsung SSD

I wanted to also switch from DOS to Linux and i thought i had found the perfect solution with GroovyArcade.
So i flashed a USB-Drive and installed it to the SSD.  (GroovyArcade-Arch2012.06.09-x86_64.iso)
It boots up fine and it runs advance menu as the front end.
Now to my problem. I can not get groovymame to run reliably.
I had to switch from opengl to d3d or ddraw for my rig to run emulation. Throttle does not seem to work at all.
If i go into the groovyarcade setup and define my monitor as Vesa 800*600 all the games run at 180-200% speed
regardless of the settings in mame.ini.
I have tried throttle, triplebuffer, Syncrefresh, refreshspeed, frameskip, in all variations without any change.

So i went into the groovyarcade setup again and switched my monitor to LCD and now everthing runs at 40% regardles
of the settings in mame.ini.

In dos mame ran fine and locked everthing down to 100%. Even dodonpachi ran without a problem. Now donkey kong
runs at either the speed of light or a snails pace.
What am i missing. I thought if i got it running at 200% it would just be a matter of putting a cap on game speed.

Is there a simple answer to this or do we need logs  to figure this one out?

Calamity

  • Moderator
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 5644
Re: GroovyMame, throttle has no effect.
« Reply #1 on: February 19, 2017, 03:33:49 pm »
You can't use d3d or ddraw video options with Linux. Those are Windows only options. By enabling those GM is failing and defaulting to software rendering, which has no v-sync support and thus it can't throttle as required. Well this is my guess because you don't provide any log. You need to manage to get GM working with -video opengl.
Important note: posts reporting GM issues without a log will be IGNORED.
Steps to create a log:
 - From command line, run: groovymame.exe -v romname >romname.txt
 - Attach resulting romname.txt file to your post, instead or pasting it.

CRT Emudriver, VMMaker & Arcade OSD downloads, documentation and discussion:  Eiusdemmodi

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31