Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Specific rom (Moon Patrol) not displaying properly?  (Read 931 times)

0 Members and 1 Guest are viewing this topic.

langlem

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 97
  • I want to build my own arcade controls!
Specific rom (Moon Patrol) not displaying properly?
« on: January 27, 2017, 12:54:32 am »
Hi all...have something that seemingly should be pretty simple to figure out but I am at a loss.  Retropie is still a bit foreign to me so I hope someone knows an easy fix.

I have a horizontal set up and my Moon Patrol rom displays with horizontal bars on each side.  Like it is being cropped for a vertical monitor.  I have added and deleted the rom. Obviously I have gone into the video settings in the tab menu and nothing seems to get it to display full screen?

Using Advmame .94 with a clean (run thru clrmamepro) rom.  Displays fine running on a pc but not on my Pi3.

Any thoughts on this? All my other horizontal games appear correct?  Attached a few pics for reference. Metal Slug appears fine....if you can tell.

Thanks in advance for any advice.

mahuti

  • Wiki Master
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 2503
  • Back from the dead.
Re: Specific rom (Moon Patrol) not displaying properly?
« Reply #1 on: January 27, 2017, 08:58:28 am »
Have you checked the dipswitch settings for the game?
Formerly known for the (apparently now defunct) arcadeartlibrary

PL1

  • Global Moderator
  • Trade Count: (+1)
  • Full Member
  • *****
  • Online Online
  • Posts: 6361
  • 2013 UCA Awardee
Re: Specific rom (Moon Patrol) not displaying properly?
« Reply #2 on: January 27, 2017, 09:29:45 am »
Moon Patrol rom displays with horizontal bars on each side.
The vertical bars on the left and right are caused by the "Pixel Aspect (20:21)" setting in the MAME "Video Options" menu.

Select "Standard (4:3)" instead.   ;D


Scott

langlem

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 97
  • I want to build my own arcade controls!
Re: Specific rom (Moon Patrol) not displaying properly?
« Reply #3 on: January 27, 2017, 03:40:29 pm »
Thanks for the replies.  I am runnung Advancemame and do not see the option to change the modes 4:3 or 20:21 as you would in "regular" mame.

Same with dipswitch settings...just the option to select cab type (upright/cocktail).

Im really at a loss?

nitrogen_widget

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 759
  • I want to build my own arcade controls!
Re: Specific rom (Moon Patrol) not displaying properly?
« Reply #4 on: January 27, 2017, 03:47:42 pm »
I think the TAB button pulls up advmame's config menu.
Choose video and you can play with the scaling options.

Moon patrol may have a weird resolution?


southpaw13

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 824
  • Whatever!
Re: Specific rom (Moon Patrol) not displaying properly?
« Reply #5 on: January 28, 2017, 10:58:25 am »
AdvanceMame does not stretch.  The screen is correct.  Try Mame2003 to fix this.

langlem

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 97
  • I want to build my own arcade controls!
Re: Specific rom (Moon Patrol) not displaying properly?
« Reply #6 on: January 28, 2017, 11:53:30 am »
Thx...yeah, I am coming to the same conclusion... Change MAME versions.

I have an ArPiCade and Dylan set it up with Moon Patrol running on AdvMame.  He must have some custom overscan settings or something.  I notice his image that the AdvMame video mode options are different than what I have.  More than likely past my skill level  :dizzy:! (As are most things)

Wouldnt be such a big deal...but this is a MOON PATROL cabinet so if there is one game I want too look "right" its, well, Moon Patrol  >:D

I only have 20 or so games on this particular project. Had them all running in AdvMame from a previous project.  Knew it wouldnt be simple of course...it never is for me.

Thx again for the input.

Grasshopper

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 2223
  • life, don't talk to me about life
Re: Specific rom (Moon Patrol) not displaying properly?
« Reply #7 on: January 28, 2017, 06:33:42 pm »
It might be caused by the issue described in the following thread:

https://github.com/raspberrypi/firmware/issues/638

If it is, then the fix is to download the latest version of advmame, as that version automatically sets framebuffer_aspect=-1 where appropriate.

"Patriotism is the last refuge of the scoundrel." - Samuel Johnson

langlem

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 97
  • I want to build my own arcade controls!
Re: Specific rom (Moon Patrol) not displaying properly?
« Reply #8 on: January 30, 2017, 10:25:47 pm »
Again, my Google skills are failing me miserably. The framebuffer aspect -1 change above works perfectly for all horizontal games.  However it skews the vertical games to fullscreen as well.

Can you have two instances of the "main" config file? Kinda like having separate ini files within mame?

Thx again.

southpaw13

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 824
  • Whatever!
Re: Specific rom (Moon Patrol) not displaying properly?
« Reply #9 on: January 31, 2017, 11:42:56 am »
So I updated my Retropie advance Mame builds and I am now seeing the frame buffer command in the config folder.  Are you using something else than Retropie?

Thanks

1500points

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 317
    • How to succeed at Robotron
Re: Specific rom (Moon Patrol) not displaying properly?
« Reply #10 on: April 20, 2017, 12:19:05 pm »
I installed all the available MAME versions on my RetroPie.
And I'm finding MAME2016 to be the most friendly for working with roms from my PC Mame world.

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31