Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Aliens: Extermination  (Read 4487 times)

0 Members and 1 Guest are viewing this topic.

Le Chuck

  • I want a new quote!
  • Wiki Contributor
  • Trade Count: (+6)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5326
  • I may have forgotten to whom I am talking.
Re: Aliens: Extermination
« Reply #40 on: February 23, 2017, 08:40:48 pm »
I'm with the herd on this one.  It'd be cool, but juice isn't worth the squeeze as is. 

MrThunderwing

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 450
  • As I pass, do I give you the ass or the crotch?
Re: Aliens: Extermination
« Reply #41 on: February 24, 2017, 05:41:34 pm »
Good metaphor! I like.

Trnzaddict

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 49
Re: Aliens: Extermination
« Reply #42 on: March 15, 2017, 03:51:31 pm »
Hey guys. Some good news going on in the original thread for this dump.

Somebody has put together a new package for the game that is only around 250 megs. It contains:
*HASP Dongle Dump
*Dongle Driver
*Dongle Emulator
*The game Folder

So there's good news and bad news.

After installing all the dongle stuff, the game works and has been tested on Win7 and Win XP.

Bad news.....only x86 versions on Windows seem to run the game. He includes x64 drivers for all the dongle stuff but when the game is executed, a pop up shows up complaining about unsigned drivers and the game comes up with an image that says ''Searching for Dongle''.
I'm sure there is some sort of setting that get it to run on the 64 bit OS.

I just wanted to get this info out there, as now that it is actually running without XPE.....maybe some of the ''tweakers'' that are around here can download this new dump and maybe get it going on x64.

Howard_Casto

  • Idiot Police
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15672
  • Your Post's Soul is MINE!!! .......Again??
    • The Dragon King
Re: Aliens: Extermination
« Reply #43 on: March 15, 2017, 04:30:42 pm »
If it's complaining about unsigned drivers then you have to put windows into "test mode" and manually install the driver.  It's the same deal with ppjoy, xbcd and similar homebrew drivers without proper signatures.

MrThunderwing

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 450
  • As I pass, do I give you the ass or the crotch?
Re: Aliens: Extermination
« Reply #44 on: March 15, 2017, 07:10:47 pm »
Hey guys. Some good news going on in the original thread for this dump.

Somebody has put together a new package for the game that is only around 250 megs. It contains:
*HASP Dongle Dump
*Dongle Driver
*Dongle Emulator
*The game Folder

So there's good news and bad news.

After installing all the dongle stuff, the game works and has been tested on Win7 and Win XP.

Bad news.....only x86 versions on Windows seem to run the game. He includes x64 drivers for all the dongle stuff but when the game is executed, a pop up shows up complaining about unsigned drivers and the game comes up with an image that says ''Searching for Dongle''.
I'm sure there is some sort of setting that get it to run on the 64 bit OS.

I just wanted to get this info out there, as now that it is actually running without XPE.....maybe some of the ''tweakers'' that are around here can download this new dump and maybe get it going on x64.

Thanks for the heads up on this! Downloading it as we speak.

POOTERMAN

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 71
    • My PC Desktop Icon Atwork
Re: Aliens: Extermination
« Reply #45 on: March 15, 2017, 10:12:15 pm »
Details on the 'Test Mode' guys:

How to Disable Driver Signature Verification on 64-Bit Windows 8 or 10 (So That You Can Install Unsigned Drivers)

https://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-so-that-you-can-install-unsigned-drivers/

Howard_Casto

  • Idiot Police
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15672
  • Your Post's Soul is MINE!!! .......Again??
    • The Dragon King
Re: Aliens: Extermination
« Reply #46 on: March 16, 2017, 03:37:04 am »
I couldn't sleep so I gave it a shot.  It still can't find the dongle, but I'll report what it did. 

As pooter explained you need to open an admin command prompt, type "bcdedit /set testsigning on" and restart your computer.  If you did it right you'll see some test mode info in the bottom left hand corner of your desktop. 

After that the hasp installer "hdd32.exe" installed fine.  The only problem with that..... note that it's the 32 bit version... we need the 64 bit one.  The reg file also merges successfully.... no surprise there.  Multikey32/install.cmd and multikey64/install.cmd both fail.  Also right-clicking on the inf files still gives driver signing complaints.  I believe that is because these are xp drivers and it doesn't necessarily have to do with the signing... I'll try some things. 

If the hardlock dongle is the "Aladdin hardlock" there are drivers on this site:

http://www.driverscape.com/download/aladdin-hardlock-key

I don't know if they are what is needed as a specific version might be required. 

So if someone is more familiar with the dongle software this should be doable. 

Titchgamer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1867
  • I have a gaming addiction.....
Re: Aliens: Extermination
« Reply #47 on: March 16, 2017, 05:12:36 am »
Thats good news :)
This may be a thing yet!!

Howard_Casto

  • Idiot Police
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15672
  • Your Post's Soul is MINE!!! .......Again??
    • The Dragon King
Re: Aliens: Extermination
« Reply #48 on: March 16, 2017, 11:52:28 pm »
So I don't know if this helps,  but poking around in the exe it looks like the dll it's looking for is "HASPUT16.DLL", which doesn't sound right at all.  That would be a windows 3.11 driver.  There is also mention of a DOS driver version as well?

Trnzaddict

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 49
Re: Aliens: Extermination
« Reply #49 on: March 17, 2017, 07:17:29 am »
So I don't know if this helps,  but poking around in the exe it looks like the dll it's looking for is "HASPUT16.DLL", which doesn't sound right at all.  That would be a windows 3.11 driver.  There is also mention of a DOS driver version as well?

No, Hasput16.dll is definitely in the xpe windows install on the dumped HDD.

I poked around the exe too in a hex editor weeks ago ...what if the lines calling for the dll and HASPDOSDVR were deleted from the eve? Maybe it could skip its checks for it?


Howard_Casto

  • Idiot Police
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15672
  • Your Post's Soul is MINE!!! .......Again??
    • The Dragon King
Re: Aliens: Extermination
« Reply #50 on: March 17, 2017, 05:05:15 pm »
That was my first thought.  Nothing I tried worked though.  What we really need is someone either with the real dongle or a working system that they can unplug/turn off.  They could run it through cheat engine and see the differences in memory if it's plugged in or unplugged.  Everything I have runs on a 64 bit os at this point, so I'm no help.

Trnzaddict

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 49
Re: Aliens: Extermination
« Reply #51 on: March 17, 2017, 06:47:36 pm »
Yea 64bit is def. a no go guys :(

So I managed to get the dongle installed on win7x64 by using a program that fake signs the Multikey64 and then by rebooting by the f8 method and disabling driver signature.

Shows up in device manager exactly how it does when running XPE...but when you start the game it still whines about the dongle.

At this point I think the game is hard coded to look for a 32bit dongle. Nothing else will work. Well at least we got it going out of the XPE enviromemt. Didn't Type X games use dongles with XPE? Surprised the guys behind all those releases haven't stabbed at this yet. It is one of the best Alien games ever made.

POOTERMAN

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 71
    • My PC Desktop Icon Atwork
Re: Aliens: Extermination
« Reply #52 on: March 17, 2017, 09:10:43 pm »
Sucks this is x64 unfriendly, would it be in theory possible to make a Windows XP x86 virtual .vxd file with all the correct drivers installed that just needs to be opened using Hyper-X virtual manager in Windows 10 x64?

Howard_Casto

  • Idiot Police
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15672
  • Your Post's Soul is MINE!!! .......Again??
    • The Dragon King
Re: Aliens: Extermination
« Reply #53 on: March 17, 2017, 11:47:54 pm »
Probably, but with it virtualized it probably isn't going to run great on most machines.  I think we need to collect all the components first.  Presently the codecs and required dlls aren't in the archive. 

Anybody know where I can get a copy of the hasput16.dll?  I want to mess with it a bit and maybe I can intercept what the game is sending to it. 

POOTERMAN

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 71
    • My PC Desktop Icon Atwork
Re: Aliens: Extermination
« Reply #54 on: March 25, 2017, 06:57:44 pm »
Just discovered there was an Aliens: Armageddon arcade game too, anybody know what hardware/OS that runs on and if that's ever likely to be emulated to work on the PC?

Howard_Casto

  • Idiot Police
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15672
  • Your Post's Soul is MINE!!! .......Again??
    • The Dragon King
Re: Aliens: Extermination
« Reply #55 on: March 25, 2017, 07:04:20 pm »
Anything made after the early 2000's most assuredly is just a glorified pc.  Now if it runs on XP or Linux or misc, I don't know. 

POOTERMAN

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 71
    • My PC Desktop Icon Atwork
Re: Aliens: Extermination
« Reply #56 on: March 26, 2017, 06:46:29 am »
Apparently Alien: Armageddon and Terminator made by PlayMechanix/Raw Thrills run on Linux Dell machines.

Brian74

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1064
  • Yep... I built that!!
Re: Aliens: Extermination
« Reply #57 on: March 26, 2017, 10:09:22 am »
I tried running terminator and bbh threw a vm, didn't get very far.
         

MrThunderwing

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 450
  • As I pass, do I give you the ass or the crotch?
Re: Aliens: Extermination
« Reply #58 on: March 26, 2017, 11:26:48 am »
Somebody's posted this solution to getting the game working over at a French forum:

Quote
I premade a virtualbox image with this fully working on 1cc.
 
In virtualbox create a new VM with the following settings:
Windows XP (32 bit)
1024mb ram
I / O APIC enabled
1 cpu core
128mb video memory
3D/2D acceleration enabled
 
When it asks you to make a new hard drive select the aliens.vhd file then run the vm, in the vm i recommend disabling mouse integration so the mouse doesn't leave the vm (right ctrl to get the mouse back)
 
ppjoy mouse to joystick is set up in the vm for controls, sensitivity can be changed on the window that opens on startup (leave it open in the background) press ok on any avi frame errors and the game will start
 
Note: Mouse may be a bit sensitive, if it is then lower the sensitivity in windows embedded and ppjoy

I haven't tried it myself yet. I can't link directly to the forum because there's a link to the game there.

MrThunderwing

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 450
  • As I pass, do I give you the ass or the crotch?
Re: Aliens: Extermination
« Reply #59 on: April 03, 2017, 03:52:38 pm »
Hooray! I managed to get this working tonight on my Windows 7 64 bit PC, using the Virtual Box method. The controls took a fair bit of fiddling with to get working, but I got there in the end.

Edit: here it is up and running

https://youtu.be/PPlgU9cZRuk
« Last Edit: April 04, 2017, 01:05:42 pm by MrThunderwing »

Titchgamer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1867
  • I have a gaming addiction.....
Re: Aliens: Extermination
« Reply #60 on: April 28, 2017, 07:57:43 am »
Finally got around to getting this working properly on my cab today! Works great with my Dual aim traks using Argons premade VM.

Much thanks to those who got this working for the masses!



Just one q, Anyone got this working via a front end?

I tried to get it working via a batch file using the command:
C:\program files\oracle\virtualbox\vboxmanage.exe startvm "aliens"

But does nothing :(

Titchgamer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1867
  • I have a gaming addiction.....
Re: Aliens: Extermination
« Reply #61 on: April 29, 2017, 07:21:49 pm »
I managed to get a shortcut working for this in hyper spin for this today.

For anyone else having trouble this is how I did it:

In vbox once all set up go to machine up the top menu and click the option for create shortcut on desktop.

This will create a working shortcut that opens the vm but it wont work with hs.

Next right click on it to enter the properties and copy the whole target address (complete with huge long number!)

Make a new txt document and paste the address link in.
Then save with a .bat extension to create a working batch file.

You can then use this batch file as a executable for hyperspin.

For some reason it would not work manually putting just the vm name in.

Brian74

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1064
  • Yep... I built that!!
Re: Aliens: Extermination
« Reply #62 on: April 29, 2017, 10:20:30 pm »
Now if we could get recoil working!!
         

Titchgamer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1867
  • I have a gaming addiction.....
Re: Aliens: Extermination
« Reply #63 on: April 30, 2017, 03:11:47 am »
The recoil on my aim trak works.
But only single shot does not work with the trigger held but I believe thats by design to stop the solenoid burning out.

Howard_Casto

  • Idiot Police
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 15672
  • Your Post's Soul is MINE!!! .......Again??
    • The Dragon King
Re: Aliens: Extermination
« Reply #64 on: April 30, 2017, 02:01:43 pm »
He means force feedback controlled by the game.  In other words I think that was a hint.  ;)

Titchgamer

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 1867
  • I have a gaming addiction.....
Re: Aliens: Extermination
« Reply #65 on: April 30, 2017, 02:23:31 pm »
Ahhh well he must be hinting at you or one of the others coz I wouldnt know where to start :p

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31