Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Megatouch Force eVo Boot Problems - Redux  (Read 595 times)

0 Members and 1 Guest are viewing this topic.

TalkingHeadsFan

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 36
  • I want to build my own arcade controls!
Megatouch Force eVo Boot Problems - Redux
« on: August 22, 2016, 08:38:27 am »
https://www.youtube.com/watch?v=MjmadNzi5NE

After a few months of my Megatouch Force eVo working fine, I start it up and this happens...No signal and repetitive beeping. I tried counting the beeps, but it doesn't stop so I can't do that. I tried reseating the RAM; no help. I tried a new CMOS battery; no help. I'm stuck on what the next step is. Is this usually indicative of a motherboard failure?  ??? :angry:

Thanks,
-Doug

lilshawn

  • Moderator
  • Trade Count: (+3)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 5577
  • I break stuff...then fix it...sometimes
Re: Megatouch Force eVo Boot Problems - Redux
« Reply #1 on: August 22, 2016, 10:25:33 pm »
CPU issue or bad RAM stick is usually what incessant ceaseless beeping is.

TalkingHeadsFan

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 36
  • I want to build my own arcade controls!
Re: Megatouch Force eVo Boot Problems - Redux
« Reply #2 on: August 23, 2016, 04:26:31 pm »
I'll swap out the RAM and see if that helps at all and report back.

TalkingHeadsFan

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 36
  • I want to build my own arcade controls!
Re: Megatouch Force eVo Boot Problems - Redux
« Reply #3 on: August 24, 2016, 12:11:11 pm »
You guys rock, it was a stick of RAM that crapped out. I swapped it out with some RAM from my Force Radion and it started right up.

Side question; has anybody ever observed condensation forming on a Megatouch LCD panel, beneath the touchscreen overlay? It only occurs when the game has been on for a while (15 minutes+). My guess is that the panel is heating up and forming visible moisture on the screen. The basement humidity is around 65-70%. I guess the only way to eliminate this is to reduce the moisture in the basement. Any insight would still be helpful.

Thanks,
-Doug

lilshawn

  • Moderator
  • Trade Count: (+3)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 5577
  • I break stuff...then fix it...sometimes
Re: Megatouch Force eVo Boot Problems - Redux
« Reply #4 on: August 24, 2016, 09:51:17 pm »
 :cheers:

BOOM! that's howedoit!

condensation? that's a new one for me.

welp, you need to do one of 2 things. either...

remove the touch overlay, clean it all up and then seal it good with some foam tape and maybe some fabric tape around the edges so no moisture can get in....

or

remove the touch overlay, clean it all up and then seal it not very good with some foam tape so there is space at the corners for any moisture that may get in there to escape.


ed12

  • Trade Count: (-1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 3824
  • it is what it is..."Nobody Said It Was Easy"....
Re: Megatouch Force eVo Boot Problems - Redux
« Reply #5 on: August 24, 2016, 09:54:24 pm »
for my overlay edges (around the outside)
I use 2-3" wide black hockey tape
works perfect.
do not forget the spacer foam tape

ed
Shipping something from the U.S. to Canada for repair/exchange?  Please use USPS to avoid (additional?/excessive?) shipping charges.  PM me if you have any questions.

obcd

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 153
  • I want to build my own arcade controls!
Re: Megatouch Force eVo Boot Problems - Redux
« Reply #6 on: August 25, 2016, 03:49:09 am »
You have products to avoid moisture for people with glasses.
Maybe you could treat the tube and inside of the touch overlay with such a product.
Sealing it completely in a very dry area might be worth testing as well.

TalkingHeadsFan

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 36
  • I want to build my own arcade controls!
Re: Megatouch Force eVo Boot Problems - Redux
« Reply #7 on: August 26, 2016, 10:17:53 pm »
Got my anti-fog lens cleaner, cloth, foam tape and went to work, I'm trying the "allow moisture to escape" approach and leaving gaps in the foam tape. Hopefully it will work out. I left the game on about an hour with no visible moisture which is a good sign...

lilshawn

  • Moderator
  • Trade Count: (+3)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 5577
  • I break stuff...then fix it...sometimes
Re: Megatouch Force eVo Boot Problems - Redux
« Reply #8 on: August 27, 2016, 05:28:04 pm »
sofarsogood

 :cheers:

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31