Main > Lightguns

DemulShooter (Dual light gun on DEMUL, Model2, Dolphin, Silent Hill, etc...)

<< < (5/669) > >>

There is no link between mouse coords in Paddemul.dll and this particular issue : coords in dll are only used for processing to the loaded game
It is not used to process mouse position/click on Demul menus, window from an OS point of view

What is causing this is (I guess) handled directly by windows, with directX and direct input. WIndows get the mouse position/events and forward these message to any application.

So the solution (if this is the case) would be pretty simple : I'll just unregister Demul from receiving any mouse event from Windows
It'll solve the issue, but at the following cost : it will not be possible to interract with Demul (well yes, with a Keyborad ! :)) . This should not be a big problem as I (personnaly) don't go into Demul menus once settings are done

I'll look into this ! This may be quick to test  :)

Ok ! So I did some test, indeed blocking mouse messages from Windows to Demul GUI is resolving this issue  :)

It comes at a price though :
1) Disabling mouse goes with disabling keyboard too
-> So no more Demul GUI navigation once a game is loaded (it's when Demul starts hacking, no game loaded = no hack = full mouse/keyboard in GUI)

2) Disabling inputs make windows produce it's "Beep" sound at each click on the window (each shoot in our case)
-> DemulShooter  will modify a registry key to set the windows beep sound effet to "none". If needed, to restore it go to Control panel > sound > and restore the sound for this one (I don't know english name, something like "default beep")

Uploaded v1.4 on 1st post, and added a command line switch to use this hack whenever you want : -noresize
Tested at home with win7 x64, and even with disabled GUI all my aimtrak buttons are OK, inputs sent by autohotkey script is OK too, and even Keyboard keypress for game input (SERVICE, TEST, START, COIN) are working

Thanks for letting me know about this demul issue ! And enjoy  :)

This sounds awesome. If you solved it then you deserve serious accolades, as it has been a problem for a long time. I can't wait to try it out.

Question, if keyboard is disabled, will that be an issue as I use IPAC to communicate my arcade cabinet buttons to the computer. It acts as a keyboard.

Sent from my iPhone using Tapatalk

well, I wondered about IPAC, etc... too and it seems that it should I tested with a keyboard for start and coin and it worked

My guess is, as PAddemul pluggin is in a different dll, inputs are not blocked for it.
I'm disabling mouse/keyboard message to demul process main window (GUI)

Overall it's still a pretty ugly hack  ;D

So I seem to be having trouble with my setup. I am using Demul 0.7a, and testing HOTD2

I executed DemulShooter (it resides in the same folder as the Demul installation) and chose the following for my guns P1 and P2

--- Code: ---P1Device = \\?\HID#VID_D209&PID_1603&MI_02#9&bb9ce79&0&0000#{378de44c-56ef-11d1-bc8c-00a0c91405dd}
P2Device = \\?\HID#VID_D209&PID_1604&MI_02#9&b6a1e27&0&0000#{378de44c-56ef-11d1-bc8c-00a0c91405dd}

--- End code ---

I then load up DemulShooter using the following command, and its running in the tray
DemulShooter.exe -demul=07a -system=naomi  -v

This is my debug.txt

--- Code: ---7:41 PM : -------------------- Program Start ----------------------
7:41 PM : Cmdline arg 1 : -demul=07a
7:41 PM : Cmdline arg 2 : -system=naomi
7:41 PM : Cmdline arg 3 : -v
7:41 PM : File not found : D:\Arcade\Demul\Demul 7a\MemoryData\07a\naomi.cfg
7:41 PM : Waiting for naomigame to hook.....
7:41 PM : Conf read OK
7:41 PM : P1 device = \\?\HID#VID_D209&PID_1603&MI_02#9&bb9ce79&0&0000#{378de44c-56ef-11d1-bc8c-00a0c91405dd}
7:41 PM : P1 device handle = 65609
7:41 PM : P2 device  = \\?\HID#VID_D209&PID_1604&MI_02#9&b6a1e27&0&0000#{378de44c-56ef-11d1-bc8c-00a0c91405dd}
7:41 PM : P2 device handle = 65613
7:42 PM : Attached to Process Demul.exe, ProcessHandle = 660
7:42 PM : Demul.exe = 0x00400000, padDemul.dll = 0x04F30000
7:42 PM : Adding CodeCave at : 0x051E0000
7:42 PM : Memory Hack complete !
7:44 PM : Demul.exe closed
--- End code ---

The issue is the game isnt seeing two guns. On the input test it registers both players with one gun. Two cursors are seen onscreen, but they both act as player 1.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version