Software Support > GroovyMAME

CRT Emudriver 2.0 - Emulator compatibility list

(1/38) > >>

Calamity:
I'm opening this thread so we can the post about the compatibility state of the different emulators available, with CRT Emudriver 2.0 and the new CRT Tools. This way I should be able to focus on fixing existing compatibility issues as fast as possible, or at least have a reference place where known issues are documented.

Because I'm focused on MAME exclusively since long, I've lost contact with other emulators. I need your help here.

Please don't go off topic in this thread. Don't use this thread to report your particular issues, questions, etc.

DirectDraw based emulators may require the ddraw.dll wrapper attached at the end of this post, in order to switch from progressive to interlaced modes and vice versa. Place the unzipped dll in the same folder where the emulator's executable you want to fix is.

Daphne
   
       - XP-32: (ATI legacy) OK
       - XP-64: (ATI legacy) OK
       - W7-64:  (ATI legacy) OK
       - W7-64:  (AMD HD 5000+) OK


Model 2

       - XP-32: (ATI legacy) OK
       - XP-64: (ATI legacy) OK
       - W7-64: (ATI legacy) OK
       - W7-64: (AMD HD 5000+) OK


Nestopia UnDead

       - XP-32: (ATI legacy) OK
       - W7-64: (ATI legacy) OK
       - W7-64: (AMD HD 5000+) OK


VBA-M (MFC version)

       - XP-32: (ATI legacy) OK
       - W7-64: (ATI legacy) OK
       - W7-64: (AMD HD 5000+) OK


Retroarch 1.3.6

       - XP-64: (ATI legacy) OK
       - W7-64: (ATI legacy) OK
       - W7-64: (AMD HD 5000+) OK (use d3d driver instead of default gl driver)


Demul

       - W7-64: (AMD HD 5000+) OK


nullDC 1.0.4

       - XP-32: (ATI legacy) OK
       - W7-64: (AMD HD 5000+) OK


Kega Fusion 3.64

       - XP-32: (ATI legacy) OK
       - W7-64: (AMD HD 5000+) OK (auto-switching not working)


Taito Type X/X2

       - XP-32: (ATI legacy) OK
       - W7-64: (ATI legacy) OK, needs +hsync
       - W7-64: (AMD HD 5000+) OK


Magic Engine 1.1.3

       - W7-64: (ATI legacy) OK
       - W7-64: (AMD HD 5000+) OK


ZSNESw 1.51

       - W7-64: (ATI legacy) OK
       - W7-64: (AMD HD 5000+) OK


OoTake 2.76

       - XP-32: (ATI legacy) OK
       - W7-64: (AMD HD 5000+) OK (auto-switching not working)


PCSX2

       - W7-64: (AMD HD 5000+) OK


Makaron T12/5

       - XP-32: (ATI legacy) OK
       - W7-64: (AMD HD 5000+) OK


WinVICE 2.2

       - W7-64: (ATI legacy) OK
       - W7-64: (AMD HD 5000+) OK


CCS64

       - W7-64: (ATI legacy) OK
       - W7-64: (AMD HD 5000+) OK


PCFX 1.0

       - W7-64: (AMD HD 5000+)  works but crashes upon exit (might be not related to driver)


ePSXe

       - W7-64: (ATI legacy) OK
       - W7-64: (AMD HD 5000+) OK


ZXSpin 0.666

        - W7-64: (AMD HD 5000+) refuses to work in fullscreen just like Ootake (open window without borders)


Realspec

        - W7-64: (AMD HD 5000+) either refuses to go fullscreen or crash


FCEUX 2.2

        - W7-64: (AMD HD 5000+) due ddraw switching bug, works only in fullscreen mode when desktop resolution is not interlaced


mGBA

        - W7-64: (AMD HD 5000+) works but always forces progressive mode so if desktop is 640x480@60i then emulator forces 640x480@60p but if desktop is 1024x240 then emulator works correctly in fullscreen mode.

haynor666:
Daphne (Windows 7 x64) - not working in fullscreen mode both in opengl and YUV mode even with -nohwaccel. Did work with CRT driver 13.1. Probably some dlls are missing.

Model2 (Windows XP x32) - not working in full screen mode when VMMaker 2.0b5 is used. Works with VMMaker 1.4b. Works good in Windows 7 x64.

Nestopia UnDead - works correctly under Windows 7 x64.

VBA-M (MFC version) - works correctly under Windows 7 x64.


Right now tests was done using Asus HD4350.  Today I'll try test Fujitsu 5450 under Windows 7 x64.

Vaderman:
Retroarch

       - XP-64: (ATI legacy) OK
       - W7-64: (ATI legacy) OK

haynor666:
Kega Fusion 3.64 (Windows 7 x64 HD5450) works but does not auto switching to desired resolutions, probably due directdraw.
DEmul (Windows 7 x64 HD5450) works but slow (expected - too weak card)
Nestopia UnDead (Windows 7 x64 HD5450) works.
VBA-M (Windows 7 x64 HD5450) works.


EDIT. I forgot to mention Taito Type X/X2 problems. Technically not emulators but some people might be interested. Under Windows 7 x64 with HD4350 VMMaker has to be set to positive sync to get 100% speed (only Spica Adventure refuses to work this way) but with 5450 and default VMMaker arcade_15 monitor all games works at 100% speed even Spica Adventure :) Really strange.

Calamity:

--- Quote from: haynor666 on January 11, 2016, 01:47:11 pm ---EDIT. I forgot to mention Taito Type X/X2 problems. Technically not emulators but some people might be interested. Under Windows 7 x64 with HD4350 VMMaker has to be set to positive sync to get 100% speed (only Spica Adventure refuses to work this way) but with 5450 and default VMMaker arcade_15 monitor all games works at 100% speed even Spica Adventure :) Really strange.

--- End quote ---

Yeah I'm interested in Taito too. Can you be more specific as to what happens exactly with Spica Adventure with HD 4350?

(The HD 5000+ cards don't suffer from the halved refresh issue with interlace, whatever the sync polarity. It's good that at least we have a workaround for legacy cards, even if not all monitors support it).

Navigation

[0] Message Index

[#] Next page

Go to full version