Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: What happened to the wiki?  (Read 2557 times)

0 Members and 1 Guest are viewing this topic.

PL1

  • Global Moderator
  • Trade Count: (+1)
  • Full Member
  • *****
  • Online Online
  • Posts: 6437
  • 2013 UCA Awardee
What happened to the wiki?
« on: March 06, 2014, 06:00:44 pm »
Things were going along fine until I tried to upload "MomsArcadeAnimationFull.gif" yesterday afternoon and the site seemed to hit a brick wall.

Now pages take 15+ minutes to kick back a "The connection was reset" message while trying to load -- only two pages loaded in 50+ tries.   :badmood:

Anyone else having trouble with the wiki?

Is it a Denial of Service attack?

Can you reboot the server, Saint?   :dunno


Scott

UPDATE: Once in a while, some pages will load very quickly, but most of the time pages still take a long time before they time out.
« Last Edit: March 06, 2014, 07:20:31 pm by PL1 »

yotsuya

  • Trade Count: (+21)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 16910
  • 2014 UCA Winner, 2014, 2015, 2016 ZapCon Winner
    • forum.arcadecontrols.com/index.php/topic,137636.msg1420628.html
Re: What happened to the wiki?
« Reply #1 on: March 06, 2014, 08:24:02 pm »
That's why we can't have anything nice around here.

Oh, and

Tapatalk fix > Wiki fix    >:D
***Build what you dig, bro. Build what you dig.***

PL1

  • Global Moderator
  • Trade Count: (+1)
  • Full Member
  • *****
  • Online Online
  • Posts: 6437
  • 2013 UCA Awardee
Re: What happened to the wiki?
« Reply #2 on: March 10, 2014, 05:04:57 am »
Still won't load the newwiki.arcadecontrols.com/index.php?title=File:MomsArcadeAnimationFull.gif page.

If I try to access that page and then go to another page in the wiki, it just keeps churning until it times out like before.

According to this, the MomsArcadeAnimationFull.gif file is close to the max size for file uploads.   :dunno


Scott

Hoopz

  • Don't brand me a troublemaker!
  • Trade Count: (+8)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5097
  • Intellivision Rocks!
Re: What happened to the wiki?
« Reply #3 on: March 10, 2014, 12:04:57 pm »
I tried a handful of links and they were loading fairly quickly.  Are there specific links you wanted tested?  Maybe its sorted out now?   :dunno
Ajax should have been named Warlord, not Swan.

First off, Hoopz is right.

PL1

  • Global Moderator
  • Trade Count: (+1)
  • Full Member
  • *****
  • Online Online
  • Posts: 6437
  • 2013 UCA Awardee
Re: What happened to the wiki?
« Reply #4 on: March 10, 2014, 04:18:12 pm »
Thanks, Hoopz.

Most pages appear to be loading quickly unless and until you try to access http://newwiki.arcadecontrols.com/index.php?title=File:MomsArcadeAnimationFull.gif.

That is the one page that never loads for me.

I've even tried re-uploading the file and a uploading a different version of the file, but it doesn't seem to help.


Scott
« Last Edit: March 10, 2014, 04:20:46 pm by PL1 »

spoot

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 688
  • Destroyer of electronics
Re: What happened to the wiki?
« Reply #5 on: March 10, 2014, 04:20:01 pm »
Um, do you really want Gif support enabled in the wiki?

PL1

  • Global Moderator
  • Trade Count: (+1)
  • Full Member
  • *****
  • Online Online
  • Posts: 6437
  • 2013 UCA Awardee
Re: What happened to the wiki?
« Reply #6 on: March 10, 2014, 04:37:13 pm »
Um, do you really want Gif support enabled in the wiki?

Are you suggesting that that could be the cause of this problem?

I understand the potential security concern with .GIFs, but that was how Saint set it up.

Felsir and I will be converting most of the .GIFs to PNGs due to the resizing problems in mediawiki.

There are a few animated .GIFs like this troublesome one -- not sure what we can do with them.   :dunno


Scott

spoot

  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 688
  • Destroyer of electronics
Re: What happened to the wiki?
« Reply #7 on: March 10, 2014, 05:23:05 pm »
Dunno, but prob not helping.  I suggest fire atm.

Yeah.....long day.........

PL1

  • Global Moderator
  • Trade Count: (+1)
  • Full Member
  • *****
  • Online Online
  • Posts: 6437
  • 2013 UCA Awardee
Re: What happened to the wiki?
« Reply #8 on: March 10, 2014, 06:15:48 pm »
Everything was working fine when I uploaded a bunch of MALA configuration screencap .GIFs so I doubt it's related to the .GIF extension.

The problem file was uploaded to the old wiki on 2 March 2008, so it's probably not an infected file.

If Saint could log in and manually delete that troublesome .GIF and page, that might help fix the problem.   :dunno

Is there any other way to roll back the database?


Scott

Felsir

  • Wiki Master
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 837
  • Creating cab artwork
    • Felsir's World
Re: What happened to the wiki?
« Reply #9 on: March 11, 2014, 10:48:22 am »
Trouble is, for deletion I have to be able to access the file- which in turn crashes the site.
I'm trying to rollback to the [empty] version via file history and delete from there...


Felsir

  • Wiki Master
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 837
  • Creating cab artwork
    • Felsir's World
Re: What happened to the wiki?
« Reply #10 on: March 11, 2014, 12:50:52 pm »
Okay. That failed  :-[ For now, the best option is to leave it as an orphaned file; until Saint can delete it for us.


Felsir

  • Wiki Master
  • Trade Count: (0)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 837
  • Creating cab artwork
    • Felsir's World
Re: What happened to the wiki?
« Reply #11 on: March 17, 2014, 06:53:15 am »
Additional info for Saint, if he has time to kill the file on the server:
http://www.mediawiki.org/wiki/Manual:Image_administration#Data_storage



saint

  • turned to the Dark Side
  • Supreme Chancellor
  • Trade Count: (+6)
  • Full Member
  • *****
  • Offline Offline
  • Posts: 5900
  • I only work in cyberspace...
    • Build Your Own Arcade Controls
Re: What happened to the wiki?
« Reply #12 on: April 11, 2014, 07:34:08 am »
Sorry guys, without going into details, my personal life is not allowing me to do much more than deal with reported spammers. First I've seen this. I deleted the MomsArcadeAnimationFull.gif file, but the page still won't load. Going to go see what I can figure out next.
--- John St.Clair
     Build Your Own Arcade Controls FAQ
     http://www.arcadecontrols.com/
     Project Arcade 2!
     http://www.projectarcade.com/
     saint@arcadecontrols.com

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31