Arcade Collecting > Merit/JVL Touchscreen

Megatouch Auto Test

<< < (2/12) > >>

smartbomb2084:
It would be the first thing I would try....

Can't help you with UK availabilty on one.. stuck here in the USA.

Contact the Daveman at the link above and he may hook you up with one or even try EbAY.

Also if you have any kind of computer type switching power supply with a 20 pin connector you can hook it up to the motherboard as a test to be sure it IS the power supply.

It will work but it probably won't fit into your cabinet correctly.

 :cheers:

didgey101:
Hi. I have a atx pc power supply I could try. Without sounding stupid can I just put it straight in to try it. Pc power supplies in the uk work on the 240 volt ac input and I know the megatouch is a usa originated machine but I take it I dont have to alter the voltage at all?

didgey101:
Me again. I have just tried my atx power supply and cmos battery from my pc and still no joy. ..

lilshawn:
you are going to have to jump start it using one of the methods i posted. it's not going to magically power up on it's own. the computer settings are still going to need to be reset.

depending on how the cabinet has been modified to work in your country depends on what, if anything, needs to be done to make your regular ATX supply work.

if they used a stepdown transformer, then you will need to switch your supply down to 110 volts to work inside the cabinet... if you are just using a cord outside plugged directly to mains, leave it at 220. if there is no stepdown transformer in the cabinet, then leave it at 220.

you could also meter test the AC input of the power supply cord with the switch turned on and see how much voltage is coming out... 110 or 220 volts.

IF the computer still refuses to boot up using either of the methods i posted earlier, then you may have a fault on the motherboard. (bad capacitors or blown power regulator.)

mahkeymike:
Pretty much what lilshawn has said. You have way too many variables with voltage, along with the fact that the ECS motherboard merit used for force are complete utter garbage. Im surprised nobody asked you this, but merit at some point sold a jumper wire cable for the ECS force board so that even if the bios settings went to default, the board will always try to power_on when power is given to the power supply. If you have that jumper wire cable already on, then you can rule out a bios setting, and more then likely the motherboard itself needs repair or is toast.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version