Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Lightguns --- Bug Reports --- Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news

  

Author Topic: FIXED: "Error 20", No Force Feedback on my Sega Super GT  (Read 5055 times)

0 Members and 1 Guest are viewing this topic.

tkeahi

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 29
  • Last login:November 12, 2017, 02:25:26 am
FIXED: "Error 20", No Force Feedback on my Sega Super GT
« on: June 29, 2013, 05:30:59 pm »
Any Model 3 FFB Experts out there?

I'm working on a Sega Super GT. Everything works except the Force Feedback...when I turn the game on, the wheel rocks L and R a few times and the screen says"Drive Board Initializing". Then after a few seconds it says "Drive Board Error". The drive board LCDs say Er 20 (Error 20). sometimes it will throw an Error 22, but mostly just Error 20.

Then manual is less than helpful on this and just says it could be a problem with the Motor, Drive Control Board, Drive Board, or wiring....which pretty much covers the entire FFB system.

My question is: how do I know whether its the motor, drive board, or drive control board causing the problem? This is my only driving cab so I can't do any parts swapping to troubleshoot.

Question 2: Assuming I can get the FFB working, can Supermodel interface directly with the original Model 3 FFB hardware?

Thanks!

Edit: The problem turned out to be a bad servo motor drive board. Changed that out and the game works great.
« Last Edit: July 20, 2013, 03:54:44 am by tkeahi »

isamu

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 656
  • Last login:March 09, 2019, 01:15:31 pm
  • I'm a llama!
Re: Help! "Error 20", No Force Feeback on my Sega Super GT
« Reply #1 on: June 30, 2013, 03:52:11 pm »
I don't think the Model 3 steering hardware is capable of interacting with a Windows PC unless some very clever wiring is done, so unfortunately Supermodel emulator is out of the picture.

It appears either your ffb motor or Model 3 drive board if fried. If that's the case, you're better off buying a PC FFB wheel like the Logitech G27 or Thrustmaster T500RS, and mounting inside the Super GT arcade cabinet, and then you can play Supermodel from there. Not to mention the benefit of having access to not only other Model 3 arcade racers but other PC racing games as well(OutRun 2006, Daytona 1, F-ZeroGX, Ridge Racer, etc).

BadMouth

  • Moderator
  • Trade Count: (+6)
  • Full Member
  • *****
  • Online Online
  • Posts: 8502
  • Last login:Today at 09:34:18 pm
  • ...
Re: Help! "Error 20", No Force Feeback on my Sega Super GT
« Reply #2 on: July 01, 2013, 11:55:59 am »
We don't get many arcade techs in this sub-forum.  Hopefully that will change someday.
You may try posting in arcade miscellaneous.  There are some techs that check that board regularly.

As far as interfacing with a PC.  It hasn't been done yet, but Aganyte mentioned that he might design an interface someday.

Here is his Model 2 interface: http://translate.google.com/translate?hl=en&ie=UTF8&prev=_t&rurl=translate.google.com&sl=fr&tl=en&twu=1&u=http://www.gamoover.net/tuto/l2m2-interfacer-un-ffb-et-volant-sega-model-12-avec-un-pc-ou-une-playstation-23

He posts on here sometimes.  This is his cab: http://forum.arcadecontrols.com/index.php/topic,122462.msg1299962.html#msg1299962

If he ever does a model 3 interface, the plans will be posted online like the Model 2 one and you'll have to build it yourself.
If you're EE inclined, he could probably point you in the right direction to design it yourself.

tkeahi

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 29
  • Last login:November 12, 2017, 02:25:26 am
Re: Help! "Error 20", No Force Feeback on my Sega Super GT
« Reply #3 on: July 01, 2013, 02:35:16 pm »
Thanks for the replies. For now, I think I am going to look for a used drive board to see if that fixes the FFB.

I'll probably put the PC to M3 interface idea on hold for a while....I'm no EE, so that kind of stuff is way above my level.

I did find a post over on the supermodel forums that 'bigpanik' was working on an interface:

http://www.supermodel3.com/Forum/viewtopic.php?f=7&t=256



BadMouth

  • Moderator
  • Trade Count: (+6)
  • Full Member
  • *****
  • Online Online
  • Posts: 8502
  • Last login:Today at 09:34:18 pm
  • ...
Re: Help! "Error 20", No Force Feeback on my Sega Super GT
« Reply #4 on: July 01, 2013, 03:24:39 pm »
Thanks for the replies. For now, I think I am going to look for a used drive board to see if that fixes the FFB.

I'll probably put the PC to M3 interface idea on hold for a while....I'm no EE, so that kind of stuff is way above my level.

I did find a post over on the supermodel forums that 'bigpanik' was working on an interface:

http://www.supermodel3.com/Forum/viewtopic.php?f=7&t=256

You might check with AndyGeezer who posted in that thread.  There probably aren't many people who know as much as him when it comes to the model 3 cabs.  http://triplemoonstar.brinkster.net/theshed/default.asp

I'm not sure how much trouble he goes to troubleshooting via email.
If you're in the UK, it might pay to just send him your ffb board for repair if that's what is needed.

According to the chart you attached, it looks like it's not getting the expected input back from the wheel when turned by the ffb motor.
First thing I would check would be the potentiometer in the wheel to make sure it is smooth from 0-5k.
Then make sure nothing in the ffb drivetrain is slipping.
« Last Edit: July 01, 2013, 03:28:03 pm by BadMouth »

isamu

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 656
  • Last login:March 09, 2019, 01:15:31 pm
  • I'm a llama!
Re: Help! "Error 20", No Force Feeback on my Sega Super GT
« Reply #5 on: July 01, 2013, 10:24:10 pm »
Good advice Badmout.

Good luck Tk and let us know how it turned out :)

MartinJames

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 86
  • Last login:December 24, 2018, 09:58:23 am
Re: Help! "Error 20", No Force Feedback on my Sega Super GT
« Reply #6 on: July 05, 2013, 10:22:54 am »
I had this on My F355's Unplugged every plug int eh cab for feedback and re attached. All went away.

tkeahi

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 29
  • Last login:November 12, 2017, 02:25:26 am
Re: FIXED: "Error 20", No Force Feedback on my Sega Super GT
« Reply #7 on: July 20, 2013, 03:56:55 am »
Thanks for all the help, guys. I finally got this fixed...the problem turned out to be a bad servo motor drive board.