Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: PS/2 Trackball Configuration Help  (Read 3665 times)

0 Members and 1 Guest are viewing this topic.

tokyorock

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 13
PS/2 Trackball Configuration Help
« on: August 19, 2012, 02:11:12 pm »
I have been trying to get my 2 1/4" trackball that plugs into the PS/2 mouse port on my computer to respond to MAME, but I've had no luck. Specifically, I was trying to get it to respond in Centipede so I would be able to move the character around by using my trackball.

This is the text written within the controls.ini file I am using with MAME.
Quote
[centiped]
gamename=Centipede (revision 3)
numPlayers=2
alternating=1
mirrored=1
tilt=1
cocktail=1
usesService=0
miscDetails=
P1NumButtons=1
P1Controls=Trackball+trackball
P1_BUTTON1=Fire
P1_TRACKBALL_X=Left
P1_TRACKBALL_X_EXT=Right
P1_TRACKBALL_Y=Up
P1_TRACKBALL_Y_EXT=Down

Maybe changing the P1_TRACKBALL to a mouse command would fix the problem, but I'm quite clueless on how to properly write it out.

Any help is welcome.

mickkn

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 26
PS/2 Trackball Configuration Help
« Reply #1 on: August 19, 2012, 03:06:21 pm »
Use mouse=1 in the mame.ini? Or something like that


Sent from my iPad using Tapatalk HD

tokyorock

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 13
Re: PS/2 Trackball Configuration Help
« Reply #2 on: August 19, 2012, 07:15:56 pm »
Use mouse=1 in the mame.ini? Or something like that

It worked. Something so simple.

Well, I guess that's good for me. Less chance to mess something up. :D

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31