Main Restorations Software Audio/Jukebox/MP3 Everything Else Buy/Sell/Trade
Project Announcements Monitor/Video GroovyMAME Merit/JVL Touchscreen Meet Up Retail Vendors
Driving & Racing Woodworking Software Support Forums Consoles Project Arcade Reviews
Automated Projects Artwork Frontend Support Forums Pinball Forum Discussion Old Boards
Raspberry Pi & Dev Board controls.dat Linux Miscellaneous Arcade Wiki Discussion Old Archives
Site News

Unread posts | New Replies | Recent posts | Rules | Chatroom | Wiki | File Repository | RSS | Submit news


  

Author Topic: Hantarex Polo 25" Flyback / Cap Replacment Issues  (Read 7642 times)

0 Members and 1 Guest are viewing this topic.

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5611
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #40 on: October 15, 2011, 05:19:21 pm »
why do i have a feeling its your tube thats knackered-do you have another chassis you can chuck on to see?

Arm123

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 387
  • cant resistor...
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #41 on: October 15, 2011, 11:43:07 pm »
Not another polo chassis... What other chassis are compatible with that tube ?

I guess i could just buy a universal and try it, or is there a way to pull the yoke connectors and run the chassis ?
http://www.crooklyn-halloween-haunting.com/  Its almost that time again...

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5611
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #42 on: October 16, 2011, 03:57:23 am »
any low impedence chassis will run on the polo crt,only annoyance is making a adapter for the yoke connector

is there no one you can send your chassis just to test

Arm123

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 387
  • cant resistor...
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #43 on: October 19, 2011, 04:33:14 pm »
Alright... taking another look at this.

I put insulator sheets on all the transistors / IC's that are suppose to have them.

Before trying to power the unit on... i thought that it might be a good idea to check the HOT, as its the only thing i havent replaced.

The base and emitter (pin 1 and 3) seem to be shorted together, connected to ground.  However, the collector is not shorted to ground.

I would like to swap this thing out to make sure its not leaky or shorted... perhaps i should remove and check the +130v line (light bulb) ?

I dont have the exact replacment but I have these on hand:
BU2520DF
NTE2325
D1877

Whould one of them work out ? Seems like the BU2520DF would work as it has a higher rating.

Sorry to be such a pain, i just want this thing fixed
« Last Edit: October 19, 2011, 04:39:06 pm by Arm123 »
http://www.crooklyn-halloween-haunting.com/  Its almost that time again...

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5611
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #44 on: October 19, 2011, 05:07:33 pm »
bu2520df had a damper diode built in so no good

bu 2525,bu2727,bu2530-try to go for suffix "A" as they tend to be 125 watts

erm the HOT is pretty much the first thing that craps out on a polo chassis,I thought you had already changed that

Arm123

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 387
  • cant resistor...
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #45 on: October 19, 2011, 05:11:06 pm »
Hey there Grant  ;-)

HOT was working, so i never changed it.

Ill go downtown and get a replacement. Thanks for your time
http://www.crooklyn-halloween-haunting.com/  Its almost that time again...

Arm123

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 387
  • cant resistor...
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #46 on: October 24, 2011, 03:40:56 pm »
Changed the HOT with a BU508a, still have continuity between the base and emitter, even with the HOT pulled out (is that normal ? doesnt look like it on the diagram).

Same crap... ill have to keep looking
http://www.crooklyn-halloween-haunting.com/  Its almost that time again...

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5611
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #47 on: October 24, 2011, 05:58:37 pm »
you should pick up almost short as there is a few components linking the base/emitter

the fault you have must be on horizontal deflection circuit,you proved the power supply was fine by removing flyback and putting the lightbulb-as long as all the test point voltages are fine then it's likely to point to a problem with the circuit controlling the horizontal drive
lots of things to check if you read the schem-starting at pin 3 of ic104

Arm123

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 387
  • cant resistor...
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #48 on: October 26, 2011, 02:12:03 pm »
Hey there Grant. Yup, i see that... I checked R222 and R223, both are good :-(  I thought i was on to something, but your right.

I replaced the HOT and it blew again... went threw 2 HOTs, so i guess there is still a short somewhere.

Ill check the components on the line you mentioned... I already checked most of em.  Perhaps, i should just replace the diodes, one just may be leaky.

Thanks so much for your help Grant, i dont mean to be a pain.
http://www.crooklyn-halloween-haunting.com/  Its almost that time again...

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5611
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #49 on: October 26, 2011, 03:03:45 pm »
if the bu508a is shorting then either one of the high voltage caps on the h deflection is short,d116 is short or your tube is knackered
imo a bu508a is underpowered for this chassis,it should be a bu2520

be quicker and cheaper to send it to me

Arm123

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 387
  • cant resistor...
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #50 on: November 02, 2011, 02:57:41 pm »
I hear you Grant... but im so far into this thing, that even if you fixed it, id probaly take a shotgun to it if it died again.

I looked at the solid caps c172 , c173, c174 qnd 172 seems leaky when installed, but tested fine when out.

Im thinking i should replace all of them, cuz one has a burn mark that it came in here with c174.  I made a quick repair to the trace and it worked, but its possible it could be bad since the HOT keeps blowing.

Where can i get these ?  Is there an electrolytic value cap i can use ?
http://www.crooklyn-halloween-haunting.com/  Its almost that time again...

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5611
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #51 on: November 02, 2011, 03:00:33 pm »
c174 would cause the problem,a short high voltage on the hot will blow it all the time
you need to replace with polypropylene caps-exact spec mate

corycet

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 25
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #52 on: November 04, 2011, 07:23:44 pm »
Hi arm123,

Sorry to see your having so much trouble with this thing. After reading all of the replies I am wishing I had stepped in sooner, as I think I could have saved you a lot of grief. When you said that their was a pin missing from the flyback I knew it was folded underneath because they usually ship that way. Based on the symptoms you were having I think it would have worked if that pin was correctly placed. It sounds like you have additional problems now, which I will try to help you with.
First thing, in the future always replace the HOT with the flyback even if it tests good. In the past I have tried replacing just the flyback and end up with a shorted hot and sometimes other shorted components a month or so later. When the flyback goes bad it stresses the HOT. Also, Bob Roberts supplies the HOT for the Polo for future reference.

Before starting any troubleshooting or parts replacement, checking for bad solder joints on the entire board. the large solder joints especially. This is very common problem with this model and resoldering those bad joints can fix a lot of strange issues and future problems. Once you have completed that double check your work on your cap kit. I have found that hard to fix units are usually a result of a simple mistake from replacing a part with the wrong value or inserting it backwards.
Also check to make sure that there are no resistors or diodes by the flyback that are touching the metal casing surrounding it. There is not much room to get the flyback in place and it can hit the components around it causing them to touch the metal casing. Once these steps are completed and verified, check the 2 damper diodes by the HOT. They often short and the locations for the diodes are d134 and d135. They are fast switching diodes so don't use any diode off the shelf if they are shorted. Also, what type of test equipment do you have? If you have a DMM or oscilloscope, then the light bulb tests are unnecessary. If you need further assistance feel free to shoot me an email and I will give you my number so we can work this thing out by phone.


Arm123

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 387
  • cant resistor...
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #53 on: December 28, 2011, 11:45:19 pm »
Hey there, thanks so much for your reply

It was indeed that the flyback pin was bent back... I have since replaced all the HV poly caps and rechecked my work... all is well. I also have a fully working chassis which helped me verify that its not the yoke.

Now i am seeing a repeating spark right near the damper diodes and c174 when i start it up.

Tomorrow, ill replace the flyback and HOT... plus check the diodes... the saga continues  ;-p
http://www.crooklyn-halloween-haunting.com/  Its almost that time again...

Arm123

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 387
  • cant resistor...
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #54 on: December 29, 2011, 05:16:27 pm »
ok... removed the FB and checked all the components around the heat shield.  All components tested fine and none touching the heat shield.

Connected a light bulb to r227 and the frame... Fired it up and it lite perfectly. B+ was +139v.  Not sure what this proved that i didnt prove with the light bulb connected to L103.

I replaced the FB and HOT with a fresh pair... turned on and i get the same repeating sparking near c174 and the damper diodes...

Any ideas ?
http://www.crooklyn-halloween-haunting.com/  Its almost that time again...

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5611
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #55 on: December 29, 2011, 05:26:50 pm »
what you have proved is the b+ power supply is fine
sparking could be a high voltage component arcing due to a fracture-could be the high voltage cap

Arm123

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 387
  • cant resistor...
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #56 on: December 29, 2011, 05:43:34 pm »
Hey there Grant,

Its actually c172 and d134 where the spark is happening.
http://www.crooklyn-halloween-haunting.com/  Its almost that time again...

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5611
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #57 on: December 29, 2011, 05:58:25 pm »
remove both those components and read them-you could even have a broken track

Arm123

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 387
  • cant resistor...
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #58 on: December 29, 2011, 06:33:11 pm »
replaced d134, c172 and the HOT...  now its ticking fiantly.    :dizzy:
http://www.crooklyn-halloween-haunting.com/  Its almost that time again...

grantspain

  • I personally prefer "bog trotter"
  • Trade Count: (+1)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 5611
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #59 on: December 29, 2011, 06:46:33 pm »
is it still killing the hot?

Arm123

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 387
  • cant resistor...
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #60 on: December 29, 2011, 10:53:04 pm »
Hey there Grant,

I think when the HOT is bad / dies... thats when i get the sparking on d134, c172

NOt sure what to make of this...  Do you think d134 being bad is what was killing the flyback and then killing the HOT ? I have 2 more fresh FB's... but i dont think thats the issue.  I think im looking for a shorted component somewhere.

Not sure where to look though... after pin 1 im assuming and it must be failing under load.  Could i remove the HOT and see if i still get SMPS tripping ?

http://www.crooklyn-halloween-haunting.com/  Its almost that time again...

Arm123

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 387
  • cant resistor...
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #61 on: December 29, 2011, 10:58:20 pm »
Reason i ask is to eliminate as many components as possibe... just trying to narrow down my search
http://www.crooklyn-halloween-haunting.com/  Its almost that time again...

corycet

  • Trade Count: (0)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 25
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #62 on: December 30, 2011, 12:22:32 am »
I wouldn't change out the flyback again, that shouldn't be your issue.
How is the diode sparking? Is it sparking to another component or is it sparking underneath on the trace? Also, did you replace the diode with an exact replacement? That diode is a high speed diode and cannot be replaced with a general purpose diode.
« Last Edit: December 30, 2011, 12:26:42 am by corycet »

Arm123

  • Trade Count: (+2)
  • Full Member
  • ***
  • Offline Offline
  • Posts: 387
  • cant resistor...
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #63 on: December 30, 2011, 08:41:12 pm »
Hey there,

The spark was happening right between d134 and c172

Since changing out the HOT, c172 and d134 i havent seen a spark... just hear ticking.

Gonna pull the HOT and stick a light bulb on the collector it and see what if it ticks... im taking a wild guess here, but if it lights up and there is no ticking, then that eliminates everything up till T114...  and i should start looking at all things on the base of T114... which i have already done, but hell, i may as well do it again   :angry:
http://www.crooklyn-halloween-haunting.com/  Its almost that time again...

frankrizzo2

  • Trade Count: (0)
  • Jr. Member
  • **
  • Offline Offline
  • Posts: 9
  • I want to build my own arcade controls!
Re: Hantarex Polo 25" Flyback / Cap Replacment Issues
« Reply #64 on: October 28, 2017, 03:01:00 am »
Did you ever find a solution to your problem? I'm having simular issues also. Thanks

  
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31